
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" lang="en-US">
	<head>
			<!-- Meta tags -->
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
	<meta name="viewport" content="width=1218" />
	<!--<meta name="viewport" content="width=1024" />-->
	<!--<meta name="viewport" content="width=device-width, initial-scale=1.0">-->
	<meta name="google-site-verification" content="bBuHZdxdwW3W8iMT758WT6N3fo38yHZ-87h4XzOMyXw" />

	<!-- Schema.org -->
	<!--
	<meta itemprop="name" content="Dominica News Online" />
	<meta itemprop="image" content="https://scontent-a-ord.xx.fbcdn.net/hphotos-xaf1/t1.0-9/1002833_566348066744395_1461033157_n.jpg" />	
	<meta itemprop="description" content="Get breaking news from the #1 news website in the Commonwealth of Dominica." />
	-->
	
	<!-- Open Graph -->
	<!--
	<meta property="og:title" content="Dominica News Online" />
	<meta property="og:image" content="https://scontent-a-ord.xx.fbcdn.net/hphotos-xaf1/t1.0-9/1002833_566348066744395_1461033157_n.jpg" />
	<meta property="og:description" content="Get breaking news from the #1 news website in the Commonwealth of Dominica." />	
	-->
	
	<title>G.O.N Emmanuel passes away &#8211; Dominica News Online</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dominica News Online &raquo; Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/" />
<link rel="alternate" type="application/rss+xml" title="Dominica News Online &raquo; Comments Feed" href="http://dominicanewsonline.com/news/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Dominica News Online &raquo; iCal Feed" href="http://dominicanewsonline.com/news/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dominicanewsonline.com\/news\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<!-- AL2FB CSS -->
<style type="text/css" media="screen">
.al2fb_widget_comments { } .al2fb_widget_comments li { } .al2fb_widget_picture { width: 32px; height: 32px; } .al2fb_widget_name { } .al2fb_widget_comment { } .al2fb_widget_date { font-size: smaller; }</style>
<link rel='stylesheet' id='al2fb_style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/add-link-to-facebook/add-link-to-facebook.css' type='text/css' media='all' />
<link rel='stylesheet' id='ad-minister-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/css/ad-minister.css' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/awesome-weather/awesome-weather.css' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background: #005628;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-full-calendar-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-full-mobile-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full-mobile.min.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='tribe-events-calendar-mobile-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme-mobile.min.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='style-css'  href='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/style.css?ver=1519187791' type='text/css' media='all' />
<link rel='stylesheet' id='comments-css'  href='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/css/comments.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/types/vendor/toolset/toolset-common/res/lib/font-awesome/css/font-awesome.min.css' type='text/css' media='screen' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-featured-ads-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/awpcp-featured-ads/resources/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='cn-public-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/connections/assets/css/cn-user.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cn-chosen-css'  href='//dominicanewsonline.com/news/wp-content/plugins/connections/vendor/chosen/chosen.min.css' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='colorbox-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/colorbox/example1/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='sociable3-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/sociable.css' type='text/css' media='all' />
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/jquery-migrate.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/js/ad-minister-functions.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"20","ajax_url":"http:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"195997","token":"f839dbf5a8"};
/* ]]> */
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wordpress-popular-posts/public/js/wpp.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.marquee.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/ui/core.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/ui/datepicker.min.js' defer '></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/functions.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/swfobject.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.cycle2.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.cycle2.carousel.min.js' defer '></script>
<link rel='https://api.w.org/' href='http://dominicanewsonline.com/news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dominicanewsonline.com/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dominicanewsonline.com/news/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Massive fire in Tarreau' href='http://dominicanewsonline.com/news/homepage/news/general/massive-fire-at-tarreau/' />

<link rel='shortlink' href='http://dominicanewsonline.com/news/?p=195997' />
<link rel="alternate" type="application/json+oembed" href="http://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&#038;format=xml" />
<noscript><style> .administer-lazy-load { display: none; } </style></noscript><!-- Start AL2FB OGP -->
<meta property="og:title" content="G.O.N Emmanuel passes away" />
<meta property="og:type" content="article" />
<meta property="og:image" content="http://dominicanewsonline.com/news/wp-content/uploads/2018/03/GON-Emmanuel-300x225.jpg" />
<meta property="og:url" content="http://dominicanewsonline.com/news/homepage/news/g-o-n-emmanuel-passes-away/" />
<meta property="og:site_name" content="Dominica News Online" />
<meta property="og:description" content="Former magistrate G.O.N  Emmanuel who attracted significant public attention after his home at St, Aroment in Goodwill was firebombed over seven years ago while he slept, has died...." />
<meta property="fb:app_id" content="246787465390190" />
<meta property="og:locale" content="en_US" />
<!-- End AL2FB OGP -->

<!-- Comment Rating plugin Version: 2.9.32 by Bob King, http://wealthynetizen.com/, dynamic comment voting & styling. --> 
<style type="text/css" media="screen">
   .ckrating_highly_rated {background:none !important;}
   .ckrating_poorly_rated {background:none !important;}
   .ckrating_hotly_debated {background-color:#FFF0F5 !important;}
</style>

<link rel="stylesheet" type="text/css" href="http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/lightbox-gallery.css" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="alternate" type="application/rss+xml" title="Default Podcast Feed" href="http://dominicanewsonline.com/news/feed/podcast/" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://dominicanewsonline.com/news"><link rel="https://theeventscalendar.com/" href="http://dominicanewsonline.com/news/wp-json/tribe/events/v1/" />	<script type="text/javascript" language="javascript">
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-28491038-1', 'auto');
		ga('send', 'pageview');

	  // Old Code
	  /*  var _gaq = _gaq || [];
	  _gaq.push(['_setAccount', 'UA-28491038-1']);
	  _gaq.push(['_trackPageview']);

	  (function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	  })();*/
	</script>
<link rel="canonical" href="http://dominicanewsonline.com/news/homepage/news/g-o-n-emmanuel-passes-away/" />

<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
	</head>
		<body class="post-template-default single single-post postid-195997 single-format-standard tribe-no-js">
		<div id="page-wrapper" class="clearfix">
			<div id="header">
			
				<!-- Display DNO Logo and Logo Banner  -->
							<div id="logo-header-container" class="clearfix">

				<!-- Place this tag where you want the +1 button to render. -->
				<!--<div class="g-plusone" data-size="medium" data-href="http://dominicanewsonline.com"></div>-->

						
				<!-- Contains DNO Logo and social buttons -->
				<div id="logoContainer" class="clearfix">
					
					<!-- DNO Logo  -->			
					<a href="http://dominicanewsonline.com/news">
						<img alt="Dominica News Online | Independent. Immediate. Trusted." 
						src="http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/images/DNO-Logo.png" />
					</a>

							<!-- Social buttons -->
		<div id="social_buttons">
		
			<!-- Facebook 'Like' button -->
			<div class="fb-like" style="vertical-align: top; margin-right: 5px; max-height: 20px; display: inline-block;" data-href="http://www.facebook.com/DominicaNewsOnline" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false"></div>
		
			<!-- Twitter 'Follow' button -->
			<a class="twitter-follow-button" href="https://twitter.com/DNONews" data-show-count="false" data-show-screen-name="false">Follow @DNONews</a>

			<!-- Google +1 button -->
			<!--<div class="g-plusone" data-size="medium" data-href="http://dominicanewsonline.com"></div>-->

		</div>	
						
				</div> <!-- .logoContainer -->
			
				<div  data-timeout='15000' data-fx='scroll' class='logoBanner tcycle administer-ad-container'><div id='ad-286' class='administer-ad'><a id='adlink-286' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_286=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fcarnival-2018-calypsos%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Carnival 2018 Calyposos'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/02/Carnival-2018-Calypsos-642-1.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div><div id='ad-25' class='administer-ad'><a id='adlink-25' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_25=https%3A%2F%2Fsecure.moneygram.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Logo (Money Gram)'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/MoneyGram-Mar-8.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div></div>						
			</div> <!-- .logo-header-container -->
							
									
					<!-- Main Menu  -->
					<div class="menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-60267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-60267"><a href="http://dominicanewsonline.com/news/"><i class="fa fa-home"></i> Home</a></li>
<li id="menu-item-109591" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109591"><a href="http://dominicanewsonline.com/news/category/homepage/news/">News</a></li>
<li id="menu-item-109606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109606"><a href="http://dominicanewsonline.com/news/category/announcements/">Announcements</a>
<ul class="sub-menu">
	<li id="menu-item-141462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141462"><a href="http://dominicanewsonline.com/news/category/announcements/death-announcements/">Death Announcements</a></li>
	<li id="menu-item-141463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141463"><a href="http://dominicanewsonline.com/news/category/announcements/general-announcements/">General Announcements</a></li>
</ul>
</li>
<li id="menu-item-109592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109592"><a href="http://dominicanewsonline.com/news/category/homepage/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-109593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109593"><a href="http://dominicanewsonline.com/news/category/homepage/columns/alive-word/">Alive Word</a></li>
	<li id="menu-item-109594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109594"><a href="http://dominicanewsonline.com/news/category/homepage/columns/cariman/">CariMAN</a></li>
	<li id="menu-item-109595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109595"><a href="http://dominicanewsonline.com/news/category/homepage/columns/dear-bella/">Dear Bella</a></li>
	<li id="menu-item-109596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109596"><a href="http://dominicanewsonline.com/news/category/homepage/columns/ghost-stories/">Ghost Stories</a></li>
	<li id="menu-item-109597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109597"><a href="http://dominicanewsonline.com/news/category/homepage/columns/health-talk/">Health Talk</a></li>
	<li id="menu-item-109598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109598"><a href="http://dominicanewsonline.com/news/category/homepage/columns/just-dennis/">Just Dennis</a></li>
	<li id="menu-item-109599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109599"><a href="http://dominicanewsonline.com/news/category/homepage/columns/natural-healing/">Natural Healing</a></li>
	<li id="menu-item-109600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109600"><a href="http://dominicanewsonline.com/news/category/homepage/columns/stay-well-sparkle/">Stay Well &#038; Sparkle!</a></li>
</ul>
</li>
<li id="menu-item-109601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109601"><a href="http://dominicanewsonline.com/news/category/homepage/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-109602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109602"><a href="http://dominicanewsonline.com/news/category/homepage/features/business-features/">Business In Focus</a></li>
	<li id="menu-item-109603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109603"><a href="http://dominicanewsonline.com/news/category/homepage/features/check-this-out/">Check This Out</a></li>
	<li id="menu-item-109604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109604"><a href="http://dominicanewsonline.com/news/category/homepage/features/commentary/">Commentary</a></li>
	<li id="menu-item-109605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109605"><a href="http://dominicanewsonline.com/news/category/homepage/features/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-109607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109607"><a href="http://dominicanewsonline.com/news/category/homepage/features/photo-of-the-day/">Photo of the Day</a></li>
	<li id="menu-item-109608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109608"><a href="http://dominicanewsonline.com/news/category/homepage/features/poetry/">Poetry Corner</a></li>
</ul>
</li>
<li id="menu-item-87503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87503"><a href="http://dominicanewsonline.com/news/business-directory/">Business Directory</a></li>
<li id="menu-item-60279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60279"><a href="http://dominicanewsonline.com/news/classifieds/">Classifieds</a></li>
<li id="menu-item-137036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137036"><a href="http://dominicanewsonline.com/news/category/gallery/">Galleries</a></li>
<li id="menu-item-157540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157540"><a href="http://dominicanewsonline.com/news/events/">Events</a></li>
<li id="menu-item-60280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60280"><a href="http://dominicanewsonline.com/news/contact/">Contact Us</a></li>
<li id="menu-item-64197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64197"><a href="http://dominicanewsonline.com/news/news-links/">News Links</a></li>
<li id="menu-item-180704" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180704"><a href="http://dominicanewsonline.com/news/category/dno-radio/">DNO Radio</a></li>
</ul></div>					
					<!-- Top Banner Advertisement -->
					<div class="menu-banner-wrapper clearfix"><div  class='menu-banner-left first-ad administer-ad-container'><div id='ad-283' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/02/Beacon-Feb-6.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></div></div></div>
					<!-- Display toolbar with ticker and search field -->
							<!-- Tool Bar with buttons, ticker, and search bar -->
		<div id="toolBar" class="clearfix">
			<!--<div class="inner">-->
				<!-- Tool Bar Buttons -->
				<div class="toolBarButtons clearfix">				
					<a class="SubscribeLink" target="_blank" title="Subscribe to RSS Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/"></a>
					<a class="FacebookLink" target="_blank" title="Follow us on Facebook" href="http://www.facebook.com/DominicaNewsOnline"></a>
					<a class="TwitterLink" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"></a>
				</div>

				<!-- Ticker -->
				<div id="ticker" class="ticker">					    	
					<!--<marquee behavior="scroll" scrollamount="2" direction="left">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</marquee>-->
					<div class="marquee">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</div>
				</div> <!-- #ticker -->

				<!-- Search Bar -->
				<form id="searchBar" name="searchBar" method="get" action="http://dominicanewsonline.com/news">
					<input id="searchField" type="search" name="s" placeholder="Search the site..." value="">
					<input id="searchButton" type="button" title="Search" value=" ">
				</form>
			<!--</div>-->
		</div> <!-- #toolbar -->
							
				
			</div> <!-- #header -->
	<div class="container page-content">
				
		<!-- Load post content -->
		<!-- MAIN CONTENT: Start of Single.php content -->
<div id="content" class="first grid8 clearfix">
		
	<!-- Headline Banner: Wide ad at top of post page -->
	<div  data-timeout='15000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='ad-301' class='administer-ad'><a id='adlink-301' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_301=https%3A%2F%2Fwww.facebook.com%2Fzaimisolmosvisualarts%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Zaimis Olmos Visual Arts'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2017/11/Banner-Online-Zaimis-Olmos-Visual-Arts-1.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div><div id='ad-22' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/02/FirstDomesticFeb6.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></div><div id='ad-18' class='administer-ad'><a id='adlink-18' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_18=http%3A%2F%2Fwww.nbdominica.com%2Fen%2Findex.php%3Foption%3Dcom_content%26view%3Darticle%26id%3D150%3A40years-40wins-terms-conditions%26catid%3D1%3Anews' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'National Bank of Dominica (40years40wins) '); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/NBD-40years40wins-1.png' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div></div>			
	
		<!-- POST: Article Heading -->
		<div id="postHeading" class="postHeading clearfix">
			<h2>G.O.N Emmanuel passes away</h2>
						<span class="date" style="padding-left: 5px;"><strong>Dominica News Online - </strong>Saturday, March 31st, 2018 at 12:29 AM</span>
			<div style="margin-top: 5px;"><div class='sociable'><div><span class='sociable-tagline'></span></div><ul><li><a rel="nofollow" target="_blank"  href="http://www.facebook.com/share.php?u=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;t=G.O.N%20Emmanuel%20passes%20away" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/facebook.png" class="sociable-img" title="Facebook" alt="Facebook" /></a></li><li><a rel="nofollow" target="_blank"  href="http://twitter.com/home?status=G.O.N%20Emmanuel%20passes%20away%20-%20http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/twitter.png" class="sociable-img" title="Twitter" alt="Twitter" /></a></li><li><a rel="nofollow" target="_blank"  href="http://delicious.com/post?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;title=G.O.N%20Emmanuel%20passes%20away&amp;notes=%0D%0A%0D%0AFormer%20magistrate%20G.O.N%20%C2%A0Emmanuel%20who%20attracted%20significant%20public%20attention%20after%20his%20home%20at%20St%2C%20Aroment%20in%20Goodwill%20was%20firebombed%20over%20seven%20years%20ago%20while%20he%20slept%2C%20has%20died.%0D%0A%0D%0AEmanuel%2C%20a%20war%20veteran%20who%20served%20with%20the%20British%20Royal%20Air%20" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/delicious.png" class="sociable-img" title="del.icio.us" alt="del.icio.us" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;title=G.O.N%20Emmanuel%20passes%20away" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/stumbleupon.png" class="sociable-img" title="StumbleUpon" alt="StumbleUpon" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.printfriendly.com/print/new?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/printfriendly.png" class="sociable-img" title="Print" alt="Print" /></a></li><li><a rel="nofollow" target="_blank" href="/cdn-cgi/l/email-protection#a09fd3d5c2cac5c3d49de78eef8eee859290e5cdcdc1ced5c5cc859290d0c1d3d3c5d3859290c1d7c1d986c1cdd09bc2cfc4d99dc8d4d4d08593e18592e68592e6c4cfcdc9cec9c3c1cec5d7d3cfceccc9cec58ec3cfcd8592e6cec5d7d38592e6c8cfcdc5d0c1c7c58592e6cec5d7d38592e6c78dcf8dce8dc5cdcdc1ced5c5cc8dd0c1d3d3c5d38dc1d7c1d98592e6"><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/email_link.png" class="sociable-img" title="email" alt="email" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.google.com/reader/link?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;title=G.O.N%20Emmanuel%20passes%20away&amp;srcURL=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;srcTitle=Dominica+News+Online+The+most+popular+news+site+in+the+Commonwealth+of+Dominica" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/googlebuzz.png" class="sociable-img" title="Google Buzz" alt="Google Buzz" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;title=G.O.N%20Emmanuel%20passes%20away&amp;source=Dominica+News+Online+The+most+popular+news+site+in+the+Commonwealth+of+Dominica&amp;summary=%0D%0A%0D%0AFormer%20magistrate%20G.O.N%20%C2%A0Emmanuel%20who%20attracted%20significant%20public%20attention%20after%20his%20home%20at%20St%2C%20Aroment%20in%20Goodwill%20was%20firebombed%20over%20seven%20years%20ago%20while%20he%20slept%2C%20has%20died.%0D%0A%0D%0AEmanuel%2C%20a%20war%20veteran%20who%20served%20with%20the%20British%20Royal%20Air%20" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/linkedin.png" class="sociable-img" title="LinkedIn" alt="LinkedIn" /></a></li><li><a rel="nofollow" target="_blank"  href="http://reddit.com/submit?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fg-o-n-emmanuel-passes-away%2F&amp;title=G.O.N%20Emmanuel%20passes%20away" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/reddit.png" class="sociable-img" title="Reddit" alt="Reddit" /></a></li></ul></div></div>
		</div>
		
		<!-- POST: Article Content -->
		<div id="postContent" class="postContent"><div id="attachment_196000" style="max-width: 310px" class="wp-caption alignleft"><img class="size-full wp-image-196000" src="http://dominicanewsonline.com/news/wp-content/uploads/2018/03/GON-Emmanuel.jpg" alt="" width="300" height="225" /><p class="wp-caption-text">Emmanuel died on Good Friday</p></div>
<p>Former magistrate G.O.N  Emmanuel who attracted significant public attention after his home at St, Aroment in Goodwill was firebombed over seven years ago while he slept, has died.</p>
<p>Emanuel, a war veteran who served with the British Royal Air force during World War II, earned a reputation for the stern sentences which he gave during his tenure as a magistrate in Dominica in the 1980&#8217;s.</p>
<p>During the Christmas 2010 alleged arson attempt on his home, Emmanuel and his wife barely escaped with their lives and despite pledges by former Police Chief Cyril Carrette and his successor, Daniel Carbon, to fully investigate the matter, no one was ever charged.</p>
<p>“I want to assure citizens of this country that this matter is being investigated professionally&#8230;..,” Carbon told DNO in January 2013 shortly after becoming  Police Commissioner.  “We must find the truth on G.O.N Emmanuel, we must investigate this matter, to dot every I and cross every T.”</p>
<p>However, eight years later, despite a confession by an individual claiming to set the fire, no charges have been brought. Many I&#8217;s remain undotted and many T&#8217;s uncrossed.</p>
<p>The former magistrate has gone to his grave with the belief that there was &#8220;a conspiracy to pervert the course of justice within the Police Force, and involving the Commissioner of police and the Executive Branch of the Commonwealth of Dominica&#8221; which he expressed in a letter to then-president Nicholas Liverpool in late 2011.</p>
<p>Emmanuel was also denied closure in another legal matter in which he filed charges against his former law firm partner Stephen Isidore, claiming that millions of dollars had allegedly passed through the partnership accounts without his knowledge and had not been accounted for.</p>
<p>The criminal charges against Isidore were not served as Isidore and his legal team, led by senior counsel, Tony Astaphan, were successful in getting the high court to grant an order of stay to prevent more than 42 charges brought by Emmanuel from being read to Isidore.</p>
<p>The charges against Isidore were filed in 2010 some months before the firebombing of Emmanuel&#8217;s residence. Like the firebombing matter, it has languished in the court for more than seven years.</p>
</div>
			
				
		<!-- Copyright information -->
		<div class="post-copyright clearfix">
			<p>
				Copyright 2012 Dominica News Online, DURAVISION INC. All Rights Reserved. This material may not be published, broadcast, rewritten or distributed.			</p>
		</div>

				
		
		<div class="clearfix">
			<!-- Related Posts -->
						<div id="relatedPosts" class="widget first grid4">
				<h3>Related Articles</h3>
				<div class="newsItems">
					<ul>
						<ul><li><a href="http://dominicanewsonline.com/news/homepage/news/crime-court-law/g-o-n-emmanuel-case-not-forgotten-carbon/" rel="bookmark" title="January 2, 2013">G.O.N Emmanuel case not forgotten &#8211; Carbon</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/crime-court-law/emmanuelisidore-court-matter-hits-snag/" rel="bookmark" title="December 18, 2012">Emmanuel/Isidore court matter hits snag</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/crime-court-law/evidence-quite-compelling-emmanuel/" rel="bookmark" title="December 22, 2010">Evidence quite compelling – Emmanuel</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/crime-court-law/govt-has-not-taken-any-sides-yet-ag-levi-peters/" rel="bookmark" title="January 17, 2011">Gov’t has not taken any sides – AG Levi Peter</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/crime-court-law/hearing-for-emanuel-isidore-matter-moves-to-higher-court/" rel="bookmark" title="December 7, 2010">UPDATE: Hearing for Emanuel, Isidore matter moves to higher court</a></li>
</ul><!-- Similar Posts took 76.826 ms -->			   
					</ul>
				</div>
			</div>
					
			
			<div  class='grid4 first-ad administer-ad-container'><div id='ad-7' class='administer-ad'><iframe width="306" height="250" src="https://www.youtube.com/embed/N7UJgeBrUbg" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></div></div>				
			
		</div>

				
		<!-- Footer Banner --> 				
			
		<!-- Comments Section -->
		<div id="commentContainer" class="clearfix">
			

<!-- The Comments Template -->
<div id="comments" class="first grid8 clearfix">            
	
	<!-- Run some checks for bots and password protected posts -->
		
	<!-- Display disclaimer -->
	<div id="disclaimer">	
			<p>
				<b>Disclaimer:</b> The comments on this page do not necessarily reflect the views of 
				DominicaNewsOnline.com/Duravision Inc. All comments are approved by DominicaNewsOnline.com 
				before they are posted. We never censor based on political or ideological points of view, 
				but we do try to maintain a sensible balance between free speech and responsible moderating.
				<br /><br />
				We <b>will</b> delete comments that:
			</p>
			<ul>
				<li>violate or infringe the rights of any person, are defamatory or harassing or include personal attacks</li>
				<li>are abusive, profane or offensive</li>
				<li>contain material which violates or encourages others to violate any applicable law</li>
				<li>promote hatred of any kind</li>
				<li>refer to people arrested or charged with a crime as though they had been found guilty</li>
				<li>contain links to "chain letters", pornographic or obscene movies or graphic images</li>
				<li>are excessively long and off-message</li>
			</ul>
			<p>
				See our full <a href="http://dominicanewsonline.com/news/policies/#comment-policy">comment/user policy/agreement.</a>
			</p>
		</div>		

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Post a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/homepage/news/g-o-n-emmanuel-passes-away/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+DominicaNewsOnline+%28Dominica+News+Online%29#respond" style="display:none;">Cancel</a></small></h3>			<form action="http://dominicanewsonline.com/news/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span>.</p><p class="comment-form-comment"><label for="comment">Comment
	<!-- Custom Smilies - Version 2.9.2 -->
	<style type="text/css">
	img.wp-smiley-select {cursor: pointer;}
	</style>
    <script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
    function grin(tag) {
    	if (typeof tinyMCE != 'undefined') {
    		grin_tinymcecomments(tag);
    	} else {
    		grin_plain(tag);
    	}
    }
    function grin_tinymcecomments(tag) {
    	tinyMCE.execCommand('mceInsertContent', false, ' ' + tag + ' ');
    }
    
    function grin_plain(tag) {
    	var myField;
    	var myCommentTextarea = "comment";
    	tag = ' ' + tag + ' ';
        if (document.getElementById(myCommentTextarea) && document.getElementById(myCommentTextarea).type == 'textarea') {
    		myField = document.getElementById(myCommentTextarea);
    	} else {
    		return false;
    	}
    	if (document.selection) {
    		myField.focus();
    		sel = document.selection.createRange();
    		sel.text = tag;
    		myField.focus();
    	}
    	else if (myField.selectionStart || myField.selectionStart == '0') {
    		var startPos = myField.selectionStart;
    		var endPos = myField.selectionEnd;
    		var cursorPos = endPos;
    		myField.value = myField.value.substring(0, startPos)
    					  + tag
    					  + myField.value.substring(endPos, myField.value.length);
    		cursorPos += tag.length;
    		myField.focus();
    		myField.selectionStart = cursorPos;
    		myField.selectionEnd = cursorPos;
    	}
    	else {
    		myField.value += tag;
    		myField.focus();
    	}
    }
    
    function moreSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'inline';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:lessSmilies()">&laquo;&nbsp;less</a></span>';
    }
    
    function lessSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'none';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:moreSmilies()">more&nbsp;&raquo;</a>';
    }
    </script>
<img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_smile.gif' alt=':)' onclick='grin(":)")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_biggrin.gif' alt=':-D' onclick='grin(":-D")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_wink.gif' alt=':wink:' onclick='grin(":wink:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_sad.gif' alt=':(' onclick='grin(":(")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_eek.gif' alt='8-O' onclick='grin("8-O")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif' alt=':lol:' onclick='grin(":lol:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_neutral.gif' alt=':-|' onclick='grin(":-|")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cry.gif' alt=':cry:' onclick='grin(":cry:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cool.gif' alt='8)' onclick='grin("8)")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_confused.gif' alt=':-?' onclick='grin(":-?")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_razz.gif' alt=':-P' onclick='grin(":-P")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mad.gif' alt=':-x' onclick='grin(":-x")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_question.gif' alt=':?:' onclick='grin(":?:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_redface.gif' alt=':oops:' onclick='grin(":oops:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_twisted.gif' alt=':twisted:' onclick='grin(":twisted:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mrgreen.gif' alt=':mrgreen:' onclick='grin(":mrgreen:")' class='wp-smiley-select' /> <span id="wp-smiley-more" style="display:none"><img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif' alt=':roll:' onclick='grin(":roll:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_idea.gif' alt=':idea:' onclick='grin(":idea:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_evil.gif' alt=':evil:' onclick='grin(":evil:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_arrow.gif' alt=':arrow:' onclick='grin(":arrow:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_surprised.gif' alt=':-o' onclick='grin(":-o")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_exclaim.gif' alt=':!:' onclick='grin(":!:")' class='wp-smiley-select' /> </span> <span id="wp-smiley-toggle"><a href="javascript:moreSmilies()">more&nbsp;&raquo;</a></span></label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"  onkeydown="gcllCounter(this)" onkeyup="gcllCounter(this)" ></textarea></p><span class="countdownbox">
<input readonly="readonly" type="text" id="commentlen" size="4" maxlength="4" value="1000" style="width:auto;text-indent:0;" />
&nbsp;characters available
</span><p class="comment-form-author"><label for="author">Name <span class="required">*</span> </label> <input id="author" name="author" type="text" value="" size="45" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span> </label> <input id="email" name="email" type="text" value="" size="45" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="45" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='195997' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c97b982a03" /></p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="119"/></p>			</form>
			</div><!-- #respond -->
	
</div> <!-- #comments -->
		</div>

	</div> <!-- #post -->	
		<!-- Load sidebar  -->
		
<div id="sidebar" class="sidebar">

	<!-- Static sidebar  -->
	
	<!-- Promo Side Banner -->
	
	<!-- Place Ezetop widget slot -->
					

	<!-- Related Posts -->
	 

			

			
		
	<!-- End of Static sidebar -->
	
	<!-- Dynamic sidebar -->
	<div id="administerwidget-56" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='ad-234' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2017/08/EPICadAug.jpg' style='width: 306px; height: 140px; ' width='306' height='140'   /></div></div></div><div id="administerwidget-48" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='ad-20' class='administer-ad'><a id='adlink-20' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_20=http%3A%2F%2Fwww.archip.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Right (Distribution)'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/03/Archipelago-Mar-9.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="administerwidget-47" class="widget widget_administerwidget"><div  data-timeout='15000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='ad-275' class='administer-ad'><a id='adlink-275' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_275=https%3A%2F%2Fwww.facebook.com%2FRUINS-ROCK-Worlds-Heritage-Caf%25C3%25A9-188675788354735%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'L'homme's Business Heritage Group '); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/03/Lhomme-Heritage-306.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div><div id='ad-259' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=250&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/KFC-BigBox-306x250.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></div></div></div><div id="tribe-events-list-widget-3" class="widget tribe-events-list-widget"><h2 class="widgettitle">Upcoming Events</h2>

	<ol class="tribe-list-widget">
					<li class="tribe-events-list-widget-events type-tribe_events post-195874 tribe-clearfix tribe-event-featured">
									<div class="tribe-event-image">
						<a href="http://dominicanewsonline.com/news/event/dominica-got-talent/"><img width="978" height="560" src="http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978.png 978w, http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978-300x172.png 300w, http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978-768x440.png 768w, http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978-642x368.png 642w" sizes="(max-width: 978px) 100vw, 978px" /></a>					</div>
					
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://dominicanewsonline.com/news/event/dominica-got-talent/" rel="bookmark">Dominica Got Talent</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">April 1 @ 8:00 pm</span>				</div>

							</li>
			</ol><!-- .tribe-list-widget -->

	<p class="tribe-events-widget-link">
		<a href="http://dominicanewsonline.com/news/events/" rel="bookmark">View All Events</a>
	</p>

</div><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"Dominica Got Talent","description":"","image":"http://dominicanewsonline.com/news/wp-content/uploads/2018/03/DominicaGotTalent__978.png","url":"http://dominicanewsonline.com/news/event/dominica-got-talent/","startDate":"2018-04-01T20:00:00-04:00","endDate":"2018-04-01T20:00:00-04:00"}]
</script><div id="administerwidget-42" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='ad-63' class='administer-ad'><a id='adlink-63' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_63=http%3A%2F%2Fwww.ndfd.dm%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NDFD- Home &amp; Article Side'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/03/ndfdMarch-1.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="administerwidget-43" class="widget widget_administerwidget"><div  data-timeout='15000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='ad-175' class='administer-ad'><a id='adlink-175' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_175=http%3A%2F%2Flife101radio.net%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Life101Radio'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=250&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2017/03/Life101306x250.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div><div id='ad-80' class='administer-ad'><a id='adlink-80' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_80=http%3A%2F%2Fwww.crimestoppersdominica.org' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Crime Stoppers'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2017/03/CrimeStoppersMar10.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="polls-widget-3" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<p>Sorry, there are no polls available at the moment.</p></div>
</div> <!-- .siderbar -->	</div>

	<div  class='margin-banner-left first-ad administer-ad-container'><div id='ad-2' class='administer-ad'><a id='adlink-2' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_2=https%3A%2F%2Fwww.buymozlems.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Universal Elegance Article Margin Left'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=100&amp;h=651&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/Universal-Elegance-Mar-29-2.jpg' style='width: 100px; height: 651px; ' width='100' height='651'   /></a></div></div><div  class='margin-banner-right first-ad administer-ad-container'><div id='ad-3' class='administer-ad'><a id='adlink-3' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_3=https%3A%2F%2Fwww.buymozlems.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Universal Elegance Article Margin Right'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=100&amp;h=651&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/Universal-Elegance-Mar-29-2.jpg' style='width: 100px; height: 651px; ' width='100' height='651'   /></a></div></div>	
			<!-- FOOTER  -->
							<div id="footer" class="container">	
					<div class="footer-content">
						<!-- 'Back To Top' button -->
						<span class="back_to_top"><a title="Go to the top of the page" href="javascript:void(0)" onclick="jQuery(window).scrollTop(0); return false;"><i class="fa fa-arrow-circle-o-up fa-3x"></i><!-- Back To Top--></a></span>
						
						<!-- Social Links -->
						<div id="footerFollow" class="clearfix">
							<h3>Follow Us</h3>
							<ul>
								<li class="SubscribeLink"><a target="_blank" title="Subscribe to RSS Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/"></a></li>
								<li class="FacebookLink"><a target="_blank" title="Follow us on Facebook" href="http://www.facebook.com/DominicaNewsOnline"></a></li>
								<li class="TwitterLink"><a target="_blank" title="Follow us on Twitter" href="https://twitter.com/#!/DNONews"></a></li>
							</ul>
						</div> <!-- #footerFollow -->				
						
						<!-- Legal Information -->
						<div class="footer-links">
							<a href="http://dominicanewsonline.com/news/policies/#privacy">Privacy Policy</a>
							<a href="http://dominicanewsonline.com/news/policies/#disclaimers">Disclaimers</a>
							<a href="http://dominicanewsonline.com/news/policies/#comment-policy">Comment Policy</a>
							<a href="http://dominicanewsonline.com/news/policies/#faq">Frequently Asked Questions</a>
							<a href="http://dominicanewsonline.com/news/contact/">Contact Us</a>
						</div>
						<p><a href="http://dominicanewsonline.com/news/policies/#copyright">Copyright &#169; 2007-2018</a> Dominica News Online, Duravision Inc &#8226; Roseau, Dominica &#8226; All rights reserved.</p>				
					</div> <!-- #footer-content -->							
				</div> <!-- #footer -->
			<script type="text/javascript">
// <![CDATA[
// ]]>
</script>
<!-- Start Of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type="text/javascript">
<!--
function gcllCounter(textarea) {
if (textarea.value.length > 1000)
textarea.value = textarea.value.substring(0, 1000);
else
document.getElementById('commentlen').value = 1000 - textarea.value.length;
}
//-->
</script>
<!-- End of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='8eb9b60933448b623ff226857bc0e186';
hf4V='39e67944c1ca01a478d181397e3db179';
cm4S="form[action='http://dominicanewsonline.com/news/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
				<!-- Java SDK script for Facebook 'Like' button -->
		<div id="fb-root"></div>
		<script type="text/javascript" language="javascript">
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=246787465390190";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		</script>

		<!-- Script for Twitter 'follow' button -->
		<script type="text/javascript" language="javascript">
		!function(d,s,id){
			var js,fjs=d.getElementsByTagName(s)[0];
			if(!d.getElementById(id)){
				js=d.createElement(s);
				js.id=id;js.src="//platform.twitter.com/widgets.js";
				fjs.parentNode.insertBefore(js,fjs);
			}
		}(document,"script","twitter-wjs");
		</script>
	<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/ck-karma.js' defer '></script>
<script type='text/javascript' src='//dominicanewsonline.com/news/wp-content/plugins/connections/vendor/picturefill/picturefill.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-polls/polls-js.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/comment-reply.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/js/jquery.colorbox.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/js/jquery.tooltip.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/lightbox-gallery.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/wp-embed.min.js' defer '></script>
<script async="async" type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/akismet/_inc/form.js' defer '></script>
		</div> <!-- #page-wrapper -->
	</body>
</html>
