
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" lang="en-US">
	<head>
			<!-- Meta tags -->
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
	<meta name="viewport" content="width=1218" />
	<!--<meta name="viewport" content="width=1024" />-->
	<!--<meta name="viewport" content="width=device-width, initial-scale=1.0">-->
	<meta name="google-site-verification" content="bBuHZdxdwW3W8iMT758WT6N3fo38yHZ-87h4XzOMyXw" />

	<!-- Schema.org -->
	<!--
	<meta itemprop="name" content="Dominica News Online" />
	<meta itemprop="image" content="https://scontent-a-ord.xx.fbcdn.net/hphotos-xaf1/t1.0-9/1002833_566348066744395_1461033157_n.jpg" />	
	<meta itemprop="description" content="Get breaking news from the #1 news website in the Commonwealth of Dominica." />
	-->
	
	<!-- Open Graph -->
	<!--
	<meta property="og:title" content="Dominica News Online" />
	<meta property="og:image" content="https://scontent-a-ord.xx.fbcdn.net/hphotos-xaf1/t1.0-9/1002833_566348066744395_1461033157_n.jpg" />
	<meta property="og:description" content="Get breaking news from the #1 news website in the Commonwealth of Dominica." />	
	-->
	
	<title>Linton blames DLP for electoral reform standstill &#8211; Dominica News Online</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dominica News Online &raquo; Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/" />
<link rel="alternate" type="application/rss+xml" title="Dominica News Online &raquo; Comments Feed" href="http://dominicanewsonline.com/news/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Dominica News Online &raquo; iCal Feed" href="http://dominicanewsonline.com/news/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dominicanewsonline.com\/news\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<!-- AL2FB CSS -->
<style type="text/css" media="screen">
.al2fb_widget_comments { } .al2fb_widget_comments li { } .al2fb_widget_picture { width: 32px; height: 32px; } .al2fb_widget_name { } .al2fb_widget_comment { } .al2fb_widget_date { font-size: smaller; }</style>
<link rel='stylesheet' id='al2fb_style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/add-link-to-facebook/add-link-to-facebook.css' type='text/css' media='all' />
<link rel='stylesheet' id='ad-minister-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/css/ad-minister.css' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/awesome-weather/awesome-weather.css' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background: #005628;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-accessibility-css-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/common/src/resources/css/accessibility.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-full-calendar-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-full-mobile-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full-mobile.min.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='tribe-events-calendar-mobile-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme-mobile.min.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='style-css'  href='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/style.css?ver=1519187791' type='text/css' media='all' />
<link rel='stylesheet' id='comments-css'  href='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/css/comments.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/types/vendor/toolset/toolset-common/res/lib/font-awesome/css/font-awesome.min.css' type='text/css' media='screen' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-featured-ads-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/awpcp-featured-ads/resources/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='cn-public-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/connections/assets/css/cn-user.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cn-chosen-css'  href='//dominicanewsonline.com/news/wp-content/plugins/connections/vendor/chosen/chosen.min.css' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='colorbox-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/colorbox/example1/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='sociable3-css'  href='http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/sociable.css' type='text/css' media='all' />
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/jquery-migrate.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/js/ad-minister-functions.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"20","ajax_url":"http:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"197224","token":"a29ed05c59"};
/* ]]> */
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wordpress-popular-posts/public/js/wpp.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.marquee.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/ui/core.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/jquery/ui/datepicker.min.js' defer '></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/functions.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/swfobject.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.cycle2.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/js/jquery.cycle2.carousel.min.js' defer '></script>
<link rel='https://api.w.org/' href='http://dominicanewsonline.com/news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dominicanewsonline.com/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dominicanewsonline.com/news/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Good Hope woman celebrates 100' href='http://dominicanewsonline.com/news/homepage/news/good-hope-woman-celebrates-100/' />
<link rel='next' title='Working to make Caribbean Fisheries climate-smart' href='http://dominicanewsonline.com/news/homepage/news/regional/working-to-make-caribbean-fisheries-climate-smart/' />

<link rel='shortlink' href='http://dominicanewsonline.com/news/?p=197224' />
<link rel="alternate" type="application/json+oembed" href="http://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&#038;format=xml" />
<noscript><style> .administer-lazy-load { display: none; } </style></noscript><!-- Start AL2FB OGP -->
<meta property="og:title" content="Linton blames DLP for electoral reform standstill" />
<meta property="og:type" content="article" />
<meta property="og:image" content="http://dominicanewsonline.com/news/wp-content/uploads/2015/06/vote.jpg" />
<meta property="og:url" content="http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/" />
<meta property="og:site_name" content="Dominica News Online" />
<meta property="og:description" content="Political leader of the United Workers Party (UWP), Lennox Linton, is placing the blame for the lack of progress on electoral reform squarely at the feet of the ruling Dominica Labour Party (DLP)...." />
<meta property="fb:app_id" content="246787465390190" />
<meta property="og:locale" content="en_US" />
<!-- End AL2FB OGP -->

<!-- Comment Rating plugin Version: 2.9.32 by Bob King, http://wealthynetizen.com/, dynamic comment voting & styling. --> 
<style type="text/css" media="screen">
   .ckrating_highly_rated {background:none !important;}
   .ckrating_poorly_rated {background:none !important;}
   .ckrating_hotly_debated {background-color:#FFF0F5 !important;}
</style>

<link rel="stylesheet" type="text/css" href="http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/lightbox-gallery.css" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="alternate" type="application/rss+xml" title="Default Podcast Feed" href="http://dominicanewsonline.com/news/feed/podcast/" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://dominicanewsonline.com/news"><link rel="https://theeventscalendar.com/" href="http://dominicanewsonline.com/news/wp-json/tribe/events/v1/" />	<script type="text/javascript" language="javascript">
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-28491038-1', 'auto');
		ga('send', 'pageview');

	  // Old Code
	  /*  var _gaq = _gaq || [];
	  _gaq.push(['_setAccount', 'UA-28491038-1']);
	  _gaq.push(['_trackPageview']);

	  (function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	  })();*/
	</script>
<link rel="canonical" href="http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/" />

<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
	</head>
		<body class="post-template-default single single-post postid-197224 single-format-standard tribe-no-js">
		<div id="page-wrapper" class="clearfix">
			<div id="header">
			
				<!-- Display DNO Logo and Logo Banner  -->
							<div id="logo-header-container" class="clearfix">

				<!-- Place this tag where you want the +1 button to render. -->
				<!--<div class="g-plusone" data-size="medium" data-href="http://dominicanewsonline.com"></div>-->

						
				<!-- Contains DNO Logo and social buttons -->
				<div id="logoContainer" class="clearfix">
					
					<!-- DNO Logo  -->			
					<a href="http://dominicanewsonline.com/news">
						<img alt="Dominica News Online | Independent. Immediate. Trusted." 
						src="http://dominicanewsonline.com/news/wp-content/themes/naturalnews2015/images/DNO-Logo.png" />
					</a>

							<!-- Social buttons -->
		<div id="social_buttons">
		
			<!-- Facebook 'Like' button -->
			<div class="fb-like" style="vertical-align: top; margin-right: 5px; max-height: 20px; display: inline-block;" data-href="http://www.facebook.com/DominicaNewsOnline" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false"></div>
		
			<!-- Twitter 'Follow' button -->
			<a class="twitter-follow-button" href="https://twitter.com/DNONews" data-show-count="false" data-show-screen-name="false">Follow @DNONews</a>

			<!-- Google +1 button -->
			<!--<div class="g-plusone" data-size="medium" data-href="http://dominicanewsonline.com"></div>-->

		</div>	
						
				</div> <!-- .logoContainer -->
			
				<div  data-timeout='15000' data-fx='scroll' class='logoBanner tcycle administer-ad-container'><div id='administer-ad-286' class='administer-ad'><a id='administer-adlink-286' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_286=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fcarnival-2018-calypsos%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Carnival 2018 Calyposos'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/02/Carnival-2018-Calypsos-642-1.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div><div id='administer-ad-25' class='administer-ad'><a id='administer-adlink-25' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_25=https%3A%2F%2Fsecure.moneygram.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Logo (Money Gram)'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/MoneyGram-Mar-8.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div></div>						
			</div> <!-- .logo-header-container -->
							
									
					<!-- Main Menu  -->
					<div class="menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-60267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-60267"><a href="http://dominicanewsonline.com/news/"><i class="fa fa-home"></i> Home</a></li>
<li id="menu-item-109591" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-109591"><a href="http://dominicanewsonline.com/news/category/homepage/news/">News</a></li>
<li id="menu-item-109606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109606"><a href="http://dominicanewsonline.com/news/category/announcements/">Announcements</a>
<ul class="sub-menu">
	<li id="menu-item-141462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141462"><a href="http://dominicanewsonline.com/news/category/announcements/death-announcements/">Death Announcements</a></li>
	<li id="menu-item-141463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141463"><a href="http://dominicanewsonline.com/news/category/announcements/general-announcements/">General Announcements</a></li>
</ul>
</li>
<li id="menu-item-109592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109592"><a href="http://dominicanewsonline.com/news/category/homepage/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-109593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109593"><a href="http://dominicanewsonline.com/news/category/homepage/columns/alive-word/">Alive Word</a></li>
	<li id="menu-item-109594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109594"><a href="http://dominicanewsonline.com/news/category/homepage/columns/cariman/">CariMAN</a></li>
	<li id="menu-item-109595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109595"><a href="http://dominicanewsonline.com/news/category/homepage/columns/dear-bella/">Dear Bella</a></li>
	<li id="menu-item-109596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109596"><a href="http://dominicanewsonline.com/news/category/homepage/columns/ghost-stories/">Ghost Stories</a></li>
	<li id="menu-item-109597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109597"><a href="http://dominicanewsonline.com/news/category/homepage/columns/health-talk/">Health Talk</a></li>
	<li id="menu-item-109598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109598"><a href="http://dominicanewsonline.com/news/category/homepage/columns/just-dennis/">Just Dennis</a></li>
	<li id="menu-item-109599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109599"><a href="http://dominicanewsonline.com/news/category/homepage/columns/natural-healing/">Natural Healing</a></li>
	<li id="menu-item-109600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109600"><a href="http://dominicanewsonline.com/news/category/homepage/columns/stay-well-sparkle/">Stay Well &#038; Sparkle!</a></li>
</ul>
</li>
<li id="menu-item-109601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109601"><a href="http://dominicanewsonline.com/news/category/homepage/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-109602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109602"><a href="http://dominicanewsonline.com/news/category/homepage/features/business-features/">Business In Focus</a></li>
	<li id="menu-item-109603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109603"><a href="http://dominicanewsonline.com/news/category/homepage/features/check-this-out/">Check This Out</a></li>
	<li id="menu-item-109604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109604"><a href="http://dominicanewsonline.com/news/category/homepage/features/commentary/">Commentary</a></li>
	<li id="menu-item-109605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109605"><a href="http://dominicanewsonline.com/news/category/homepage/features/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-109607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109607"><a href="http://dominicanewsonline.com/news/category/homepage/features/photo-of-the-day/">Photo of the Day</a></li>
	<li id="menu-item-109608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109608"><a href="http://dominicanewsonline.com/news/category/homepage/features/poetry/">Poetry Corner</a></li>
</ul>
</li>
<li id="menu-item-87503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87503"><a href="http://dominicanewsonline.com/news/business-directory/">Business Directory</a></li>
<li id="menu-item-60279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60279"><a href="http://dominicanewsonline.com/news/classifieds/">Classifieds</a></li>
<li id="menu-item-137036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137036"><a href="http://dominicanewsonline.com/news/category/gallery/">Galleries</a></li>
<li id="menu-item-157540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157540"><a href="http://dominicanewsonline.com/news/events/">Events</a></li>
<li id="menu-item-60280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60280"><a href="http://dominicanewsonline.com/news/contact/">Contact Us</a></li>
<li id="menu-item-64197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64197"><a href="http://dominicanewsonline.com/news/news-links/">News Links</a></li>
<li id="menu-item-180704" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180704"><a href="http://dominicanewsonline.com/news/category/dno-radio/">DNO Radio</a></li>
</ul></div>					
					<!-- Top Banner Advertisement -->
					<div class="menu-banner-wrapper clearfix"></div>
					<!-- Display toolbar with ticker and search field -->
							<!-- Tool Bar with buttons, ticker, and search bar -->
		<div id="toolBar" class="clearfix">
			<!--<div class="inner">-->
				<!-- Tool Bar Buttons -->
				<div class="toolBarButtons clearfix">				
					<a class="SubscribeLink" target="_blank" title="Subscribe to RSS Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/"></a>
					<a class="FacebookLink" target="_blank" title="Follow us on Facebook" href="http://www.facebook.com/DominicaNewsOnline"></a>
					<a class="TwitterLink" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"></a>
				</div>

				<!-- Ticker -->
				<div id="ticker" class="ticker">					    	
					<!--<marquee behavior="scroll" scrollamount="2" direction="left">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</marquee>-->
					<div class="marquee">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</div>
				</div> <!-- #ticker -->

				<!-- Search Bar -->
				<form id="searchBar" name="searchBar" method="get" action="http://dominicanewsonline.com/news">
					<input id="searchField" type="search" name="s" placeholder="Search the site..." value="">
					<input id="searchButton" type="button" title="Search" value=" ">
				</form>
			<!--</div>-->
		</div> <!-- #toolbar -->
							
				
			</div> <!-- #header -->
	<div class="container page-content">
				
		<!-- Load post content -->
		<!-- MAIN CONTENT: Start of Single.php content -->
<div id="content" class="first grid8 clearfix">
		
	<!-- Headline Banner: Wide ad at top of post page -->
	<div  data-timeout='15000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='administer-ad-301' class='administer-ad'><a id='administer-adlink-301' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_301=https%3A%2F%2Fwww.facebook.com%2Fzaimisolmosvisualarts%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Zaimis Olmos Visual Arts'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2017/11/Banner-Online-Zaimis-Olmos-Visual-Arts-1.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div><div id='administer-ad-22' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/02/FirstDomesticFeb6.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></div><div id='administer-ad-18' class='administer-ad'><a id='administer-adlink-18' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_18=http%3A%2F%2Fwww.nbdominica.com%2Fen%2Findex.php%3Foption%3Dcom_content%26view%3Darticle%26id%3D150%3A40years-40wins-terms-conditions%26catid%3D1%3Anews' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'National Bank of Dominica (40years40wins) '); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=642&amp;h=140&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/03/NBD-40years40wins-1.png' style='width: 642px; height: 140px; ' width='642' height='140'   /></a></div></div>			
	
		<!-- POST: Article Heading -->
		<div id="postHeading" class="postHeading clearfix">
			<h2>Linton blames DLP for electoral reform standstill</h2>
						<span class="date" style="padding-left: 5px;"><strong>Dominica News Online - </strong>Tuesday, May 1st, 2018 at 9:36 AM</span>
			<div style="margin-top: 5px;"><div class='sociable'><div><span class='sociable-tagline'></span></div><ul><li><a rel="nofollow" target="_blank"  href="http://www.facebook.com/share.php?u=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;t=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/facebook.png" class="sociable-img" title="Facebook" alt="Facebook" /></a></li><li><a rel="nofollow" target="_blank"  href="http://twitter.com/home?status=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill%20-%20http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/twitter.png" class="sociable-img" title="Twitter" alt="Twitter" /></a></li><li><a rel="nofollow" target="_blank"  href="http://delicious.com/post?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;title=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill&amp;notes=Political%20leader%20of%20the%20United%20Workers%20Party%20%28UWP%29%2C%20Lennox%20Linton%2C%20is%20placing%20the%20blame%20for%20the%20lack%20of%20progress%20on%20electoral%20reform%20squarely%20at%20the%20feet%20of%20the%20ruling%20Dominica%20Labour%20Party%20%28DLP%29.%0D%0A%0D%0AHe%20said%20the%20UWP%20has%20been%20calling%20for%20electoral%20ref" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/delicious.png" class="sociable-img" title="del.icio.us" alt="del.icio.us" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;title=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/stumbleupon.png" class="sociable-img" title="StumbleUpon" alt="StumbleUpon" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.printfriendly.com/print/new?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/printfriendly.png" class="sociable-img" title="Print" alt="Print" /></a></li><li><a rel="nofollow" target="_blank" href="/cdn-cgi/l/email-protection#704f0305121a1513044d3c191e041f1e554240121c111d1503554240343c20554240161f02554240151c1513041f02111c5542400215161f021d5542400304111e140304191c1c56111d004b121f14094d18040400554331554236554236141f1d191e1913111e1507031f1e1c191e155e131f1d5542361e150703554236181f1d15001117155542361e150703554236001f1c19041913035542361c191e041f1e5d121c111d15035d141c005d161f025d151c1513041f02111c5d0215161f021d5d0304111e140304191c1c554236"><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/email_link.png" class="sociable-img" title="email" alt="email" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.google.com/reader/link?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;title=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill&amp;srcURL=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;srcTitle=Dominica+News+Online+The+most+popular+news+site+in+the+Commonwealth+of+Dominica" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/googlebuzz.png" class="sociable-img" title="Google Buzz" alt="Google Buzz" /></a></li><li><a rel="nofollow" target="_blank"  href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;title=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill&amp;source=Dominica+News+Online+The+most+popular+news+site+in+the+Commonwealth+of+Dominica&amp;summary=Political%20leader%20of%20the%20United%20Workers%20Party%20%28UWP%29%2C%20Lennox%20Linton%2C%20is%20placing%20the%20blame%20for%20the%20lack%20of%20progress%20on%20electoral%20reform%20squarely%20at%20the%20feet%20of%20the%20ruling%20Dominica%20Labour%20Party%20%28DLP%29.%0D%0A%0D%0AHe%20said%20the%20UWP%20has%20been%20calling%20for%20electoral%20ref" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/linkedin.png" class="sociable-img" title="LinkedIn" alt="LinkedIn" /></a></li><li><a rel="nofollow" target="_blank"  href="http://reddit.com/submit?url=http%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fpolitics%2Flinton-blames-dlp-for-electoral-reform-standstill%2F&amp;title=Linton%20blames%20DLP%20for%20electoral%20reform%20standstill" ><img src="http://dominicanewsonline.com/news/wp-content/plugins/sociable-30/images/default/16/reddit.png" class="sociable-img" title="Reddit" alt="Reddit" /></a></li></ul></div></div>
		</div>
		
		<!-- POST: Article Content -->
		<div id="postContent" class="postContent"><p><img class="alignleft size-full wp-image-141354" src="http://dominicanewsonline.com/news/wp-content/uploads/2015/06/vote.jpg" alt="" width="275" height="183" />Political leader of the United Workers Party (UWP), Lennox Linton, is placing the blame for the lack of progress on electoral reform squarely at the feet of the ruling Dominica Labour Party (DLP).</p>
<p>He said the UWP has been calling for electoral reform since 2005 but the calls have fallen on deaf ears have cleverly been ignored by the DLP.</p>
<p>&#8220;Since May 2005, the UWP has been calling for electoral reform along the lines of recommendations made the Chief Elections Officer and the internationally recognized observer missions,&#8221; he said.</p>
<p>The leaders of both parties have been blaming each other for the lack of progress on electoral reform on the island.</p>
<p>Just last week, Prime Minister, Roosevelt Skerrit and his deputy, Reginald Austrie, said the UWP is to be blamed. Skerrit said when the DLP took a bill to parliament to do just what the opposition and others have been calling for, in terms of electoral reform, the parliament building and the police were stoned by protesters.</p>
<p>In reality, this never happened although protests were held in opposition to matters that were being tabled by the government including amendments to the House of Assembly (Election) Act. The protesters said the amendments would legalize treating and bribery, which are electoral offenses in Dominica. Debate on the matter was subsequently adjourned without further considerations.</p>
<p>According to Linton, since March 2008 the independent Electoral Commission which has the constitutional duty to ensure free and fair elections decided on electoral reform to protect elections from bribery, voter fraud, and other corrupt election practices.</p>
<p>&#8220;An advisor to the government, a senior counsel, called it madness and advised the Prime Minister, Roosevelt Skerrit against electoral reform because it would tarnish his re-election legacy,&#8221; he stated. &#8220;I don&#8217;t tell stories, I speak truth, I speak facts.&#8221;</p>
<p>He said another senior counsel was &#8220;appointed to make sure the Electoral Commission did not achieve electoral reform as it promised in 2008.&#8221;</p>
<p>&#8220;So 10 years and two elections later, electoral reform has not happened,&#8221; he stated. &#8220;The observer mission of the OAS is not amused by that, the mission has said two years ago, quote: &#8216;the mission offers the following recommendations to further strengthen the electoral process in Dominica. It is important to point out that most of these recommendations made in 2014 were already made in 2009 by the election observer mission, however, the mission observed that virtually none of these issues were adequately addressed ahead of the 2014 elections. The mission therefore respectfully reiterate the need to implement them.'&#8221;</p>
<p>Linton stated that the &#8216;unreformed&#8217; election system in Dominica has allowed the DLP to win elections through &#8220;bribery, cheating, abuse of the people&#8217;s money, and other acts of dishonesty.&#8221;</p>
<p>&#8220;This is our reality today,&#8221; he said.</p>
</div>
			
				
		<!-- Copyright information -->
		<div class="post-copyright clearfix">
			<p>
				Copyright 2012 Dominica News Online, DURAVISION INC. All Rights Reserved. This material may not be published, broadcast, rewritten or distributed.			</p>
		</div>

				
		
		<div class="clearfix">
			<!-- Related Posts -->
						<div id="relatedPosts" class="widget first grid4">
				<h3>Related Articles</h3>
				<div class="newsItems">
					<ul>
						<ul><li><a href="http://dominicanewsonline.com/news/homepage/news/politics/uwp-reiterates-no-election-without-electoral-reform/" rel="bookmark" title="April 25, 2018">UWP reiterates &#8216;no election without electoral reform&#8217;</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/general/concern-citizens-movement-concerned-over-paralysis-in-electoral-reform/" rel="bookmark" title="January 8, 2018">Concern Citizens Movement concerned over &#8216;paralysis&#8217; in electoral reform</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/pm-skerrit-responds-to-criticism-of-governments-proposed-legislation-amendments/" rel="bookmark" title="March 5, 2016">PM Skerrit responds to criticism of government&#8217;s proposed legislation amendments</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/politics/uwp-vows-no-general-election-without-electoral-reform/" rel="bookmark" title="September 23, 2016">UWP vows no general election without electoral reform</a></li>

<li><a href="http://dominicanewsonline.com/news/homepage/news/politics/uwp-demands-electoral-reform-to-participate-in-parliament/" rel="bookmark" title="November 16, 2011">UWP demands electoral reform to participate in Parliament</a></li>
</ul><!-- Similar Posts took 86.345 ms -->			   
					</ul>
				</div>
			</div>
					
			
							
			
		</div>

				
		<!-- Footer Banner --> 				
			
		<!-- Comments Section -->
		<div id="commentContainer" class="clearfix">
			

<!-- The Comments Template -->
<div id="comments" class="first grid8 clearfix">            
	
	<!-- Run some checks for bots and password protected posts -->
		
	<!-- Display disclaimer -->
	<div id="disclaimer">	
			<p>
				<b>Disclaimer:</b> The comments on this page do not necessarily reflect the views of 
				DominicaNewsOnline.com/Duravision Inc. All comments are approved by DominicaNewsOnline.com 
				before they are posted. We never censor based on political or ideological points of view, 
				but we do try to maintain a sensible balance between free speech and responsible moderating.
				<br /><br />
				We <b>will</b> delete comments that:
			</p>
			<ul>
				<li>violate or infringe the rights of any person, are defamatory or harassing or include personal attacks</li>
				<li>are abusive, profane or offensive</li>
				<li>contain material which violates or encourages others to violate any applicable law</li>
				<li>promote hatred of any kind</li>
				<li>refer to people arrested or charged with a crime as though they had been found guilty</li>
				<li>contain links to "chain letters", pornographic or obscene movies or graphic images</li>
				<li>are excessively long and off-message</li>
			</ul>
			<p>
				See our full <a href="http://dominicanewsonline.com/news/policies/#comment-policy">comment/user policy/agreement.</a>
			</p>
		</div>		

				<div id="comments-list" class="clearfix">
				
				<!-- Display number of comments -->
				<h3>26 Comments</h3>
			
				<!-- If there are enough comments, build the comment navigation -->
				                  

				<!-- An ordered list of our custom comments callback, custom_comments(), in functions.php -->
				<ol>
						<li id="comment-2865189" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865189" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865189', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865189-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865189" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865189', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865189-down" style="font-size:12px; color:#990033;">2</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/ab3797fd107744933996a279a6aa8737?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/ab3797fd107744933996a279a6aa8737?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Peter Edwards</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Much too many political commentators without political experience. And sad to say some of you are just repeating what you hear other people say. It&#8217;s time to pray for the nation you all say you love so much. A lot is happening because we are not even consulting Almighty God about the affairs of Dominica.  All the politicians in DA are blaming each other and there us NO evidence of ANY of them trying to work together when they are elected. So blame yourselves for what is taking place in your neck of the woods and find solutions to fix them. All I hear is that most Dominicans are bought out every time there is elections. Is that on both sides of the fence? Just observing from afar.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865189#respond' onclick='return addComment.moveForm( "comment-2865189", "2865189", "respond", "197224" )' aria-label='Reply to Peter Edwards'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865183" class="comment odd alt thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865183" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865183', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865183-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865183" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865183', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865183-down" style="font-size:12px; color:#990033;">3</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/45321f1b1e0e7db3fd41cdf213fae4a8?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/45321f1b1e0e7db3fd41cdf213fae4a8?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">I is a cheater</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>The man is a cheater and if we take a close look at life in Dominica before Skerrit and compare it to since Skerrit one will not have to go far to see how Skerrit has changed Da, unfortunately for the worse. First he changed the democracy we once enjoyed with hypocrisy. If anyone asks me what type of Government we have I will know doubt tell them hypocrisy, where everything seen or heard is fake be &amp; pretense. It was Skerrit that once said that &#8221; Dominica is not a real country&#8221; and I give it to him because he was 100% correct. So yes the man has destroyed the country and I don&#8217;t think we will get better anytime soon. Again, Skerrit was so correct when he ran to the UN with his fake tears to report that &#8220;Eden was destroyed&#8221;. However he should have said that it was not Maria that destroyed Dominica but is he and the government that he leads. Sad thing though, he moved his wife and children to the US years before Erika or Maria because he knew what he was going to do.Too bad we&#8230;</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865183#respond' onclick='return addComment.moveForm( "comment-2865183", "2865183", "respond", "197224" )' aria-label='Reply to I is a cheater'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865196" class="comment even depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865196" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865196', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865196-up" style="font-size:12px; color:#009933;">1</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865196" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865196', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865196-down" style="font-size:12px; color:#990033;">2</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/40c112210e75681c3f2ff5e5576d418d?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/40c112210e75681c3f2ff5e5576d418d?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Neville</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Well said&#8230; You are spot on.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865196#respond' onclick='return addComment.moveForm( "comment-2865196", "2865196", "respond", "197224" )' aria-label='Reply to Neville'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865205" class="comment odd alt depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865205" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865205', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865205-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865205" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865205', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865205-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/394a5b82a8f59d2e77b284cb34fbbedc?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/394a5b82a8f59d2e77b284cb34fbbedc?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n"><a href='http://Yahoo' rel='external nofollow' class='url url'>Anon</a></span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>More political rubish, people like you have no idea or pretend not to know what Dominica was like before.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865205#respond' onclick='return addComment.moveForm( "comment-2865205", "2865205", "respond", "197224" )' aria-label='Reply to Anon'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
</ul><!-- .children -->
	<li id="comment-2865178" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Hot debate. What do you think? <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865178" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865178', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865178-up" style="font-size:12px; color:#009933;">5</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865178" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865178', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865178-down" style="font-size:12px; color:#990033;">5</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Canefield</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background-color:#FFF0F5 !important"><p>Dear Dominica, I am seeking your forgiveness, because I have been living in the U.S for more than 24 years and came down twice to vote for Skerrit and DLP. I don&#8217;t know how my name was still on the list but I voted.<br />
I went back last year and it was then I saw what damage I help Skerrit do to Dominica.<br />
I hope time will heal my wounds and Dominica will recovery from the mess that it is in.<br />
This time around I support change.</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865178#respond' onclick='return addComment.moveForm( "comment-2865178", "2865178", "respond", "197224" )' aria-label='Reply to Canefield'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865184" class="comment odd alt depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865184" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865184', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865184-up" style="font-size:12px; color:#009933;">3</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865184" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865184', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865184-down" style="font-size:12px; color:#990033;">4</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Man bite dogs</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Canefield, Your comment above stink, that is an old trick you have never been a Labour supporter, in a matter of fact most of the people who post nasty comments about Mr Skerrit, Labour Party are in the USA. We know it.  <img src="http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_twisted.gif" alt=":twisted:" class="wp-smiley" style="height: 1em; max-height: 1em;" /></p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865184#respond' onclick='return addComment.moveForm( "comment-2865184", "2865184", "respond", "197224" )' aria-label='Reply to Man bite dogs'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865199" class="comment even depth-3">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865199" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865199', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865199-up" style="font-size:12px; color:#009933;">1</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865199" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865199', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865199-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Massacre</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>You DLP Supporters like to use the diaspora when it suits<br />
You all eh! All the time they coming down to put Skerro back in office they were good then!<br />
But now some of them criticizing the nonsense that&#8217;s Skerro is doing<br />
All you vex!<br />
Shame on DLP for trying to play it both ways</p>
			</div>
			
			<div style="position: relative;">
							</div>
		</div>		
	</li>
</ul><!-- .children -->
</ul><!-- .children -->
	<li id="comment-2865177" class="comment odd alt thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Well-loved. Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865177" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865177', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865177-up" style="font-size:12px; color:#009933;">5</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865177" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865177', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865177-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">St. Joe</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background:none !important"><p>I support Lennox and Team Dominica in their efforts to fix the wrongs that have been plaguing Dominica over the past 18 years.<br />
We have lost so many factories and good people through migration under DLP. The strange thing about this is that some of these same people even had the guts to come down to vote DLP back in office after that same Gov&#8217;t forced them to run.!<br />
Lennox and his team will fix Dominica after Skerro lost and run to the U.S . I know for sure he will not remain in Dominica as the opposition leader.</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865177#respond' onclick='return addComment.moveForm( "comment-2865177", "2865177", "respond", "197224" )' aria-label='Reply to St. Joe'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865176" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865176" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865176', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865176-up" style="font-size:12px; color:#009933;">1</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865176" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865176', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865176-down" style="font-size:12px; color:#990033;">6</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Man bite dogs</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Here we goes those Groveling synonyms is at it again I personally fill sorry for that lots, very much sad for Workers so-called party and supporters. Sorry Linton, once again Mr Skerrit has got a lot of work on his plate at the moment, having said that Linton, you know dam well it&#8217;s not possible to have electoral reform right now, it&#8217;s all a front you playing to full your supporters, I can see right though you Mr transparent.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865176#respond' onclick='return addComment.moveForm( "comment-2865176", "2865176", "respond", "197224" )' aria-label='Reply to Man bite dogs'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865175" class="comment odd alt thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865175" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865175', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865175-up" style="font-size:12px; color:#009933;">3</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865175" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865175', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865175-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Massacre</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>It is clear that Skerrit has been manipulating the electoral reform process all along to his advantage . That was the only way to keep the names of dead people and folks who have been overseas for more than 5 years on the voters list.<br />
UWP is not in office yet, so they had no access to the ,list, Skerrit put his minions on the electoral board so he can decide what they do. But the good thing about the Skerrit mirage is that we Dominicans can see the end of his rope.<br />
My laborites friends are now telling me that they are feeling the energy that is sweeping UWP into office. They all afraid now, but I assured them that they will be served equally under UWP Government.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865175#respond' onclick='return addComment.moveForm( "comment-2865175", "2865175", "respond", "197224" )' aria-label='Reply to Massacre'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865207" class="comment even depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865207" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865207', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865207-up" style="font-size:12px; color:#009933;">0</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865207" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865207', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865207-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81646cb84e7cb48d8c9593f5a49e2a92?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Man bite dogs</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>@ Massacre, After the next General election, You so-called Workers party supporters will be Groveling creep, cringe, kneel, crawl at Dr Prime minister Skerrit, Feet wait and see u scumbags liar we going to give you low life lots the biggest whooping ever.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865207#respond' onclick='return addComment.moveForm( "comment-2865207", "2865207", "respond", "197224" )' aria-label='Reply to Man bite dogs'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
</ul><!-- .children -->
	<li id="comment-2865163" class="comment odd alt thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865163" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865163', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865163-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865163" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865163', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865163-down" style="font-size:12px; color:#990033;">2</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/4c15c05022d0f00ce03e05152770037f?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/4c15c05022d0f00ce03e05152770037f?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">zandoli</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Linton is busy engaging Skerrit on electoral reform. In the meantime, Skerrit is buying votes with money that should be used to develop the country. Who do you think will win the next election?</p>
<p>UWP keep employing the same strategy and keep losing elections, but they keep doing the same thing despite the loses. I am starting to wonder if Linton and the UWP leadership were not planted or paid by Skerrit to keep DLP in power.</p>
<p>I have a hard time believing these guys will not change course despite having a losing strategy.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865163#respond' onclick='return addComment.moveForm( "comment-2865163", "2865163", "respond", "197224" )' aria-label='Reply to zandoli'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865180" class="comment even depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865180" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865180', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865180-up" style="font-size:12px; color:#009933;">1</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865180" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865180', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865180-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/cd3dbe2988599fe7d65b493296e072e3?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Canefield</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>You are a  DLP paid distractor and will not distract concourse people of Dominica. WE all know that UWP will form the next Government of Dominica.<br />
You afraid! Even you will be protected.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865180#respond' onclick='return addComment.moveForm( "comment-2865180", "2865180", "respond", "197224" )' aria-label='Reply to Canefield'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865187" class="comment odd alt depth-3">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865187" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865187', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865187-up" style="font-size:12px; color:#009933;">0</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865187" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865187', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865187-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/4c15c05022d0f00ce03e05152770037f?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/4c15c05022d0f00ce03e05152770037f?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">zandoli</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>It&#8217;s that same mentality that will keep UWP in opposition. Every time someone suggests something constructive, UWP supporters think you are the enemy. Carry on.</p>
			</div>
			
			<div style="position: relative;">
							</div>
		</div>		
	</li>
</ul><!-- .children -->
</ul><!-- .children -->
	<li id="comment-2865153" class="comment even thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Hot debate. What do you think? <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865153" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865153', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865153-up" style="font-size:12px; color:#009933;">5</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865153" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865153', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865153-down" style="font-size:12px; color:#990033;">4</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/25950181bfb0c82354d87e0569b0a818?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/25950181bfb0c82354d87e0569b0a818?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Ibo France</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background-color:#FFF0F5 !important"><p>The present electoral system, as it is, can be easily manipulated to the advantage of the incumbent party. Campaign finance is a huge issue, the bribing of electors and overseas voters, the corrupt voters&#8217; list, the improper enumeration, and I&#8217;m just scratching the surface of the problems with this fraudulent system. Telling falsehoods seem natural to the PM for it has worked out very well for him. The Opposition is no hindrance to these well needed and urgent reforms. All Dominicans know that Dominica is governed like a monarchy, what King Skerrit wants he gets. The church, the private sector, non governmental organizations, youth groups, labor unions, every decent, fair-minded and right thinking citizen of Dominica should demonstrate throughout Roseau until this unscrupulous, double-tongue, cheating administration implements fair and well-meaning electoral reforms. This shameless strategy of apportioning blame on the Opposition for the non-implementation of reforms is laughable.</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865153#respond' onclick='return addComment.moveForm( "comment-2865153", "2865153", "respond", "197224" )' aria-label='Reply to Ibo France'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865159" class="comment odd alt depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865159" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865159', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865159-up" style="font-size:12px; color:#009933;">3</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865159" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865159', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865159-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/f28cae7c4ff8f59f86e6dd331828c161?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/f28cae7c4ff8f59f86e6dd331828c161?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">prophet for a profit</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>all we do is talk. consultations, discussion and rallies. all talk and more talk. until there is action nothing will change. there will be no electoral reform prior to the next general election. mark my words. the government is not pressed to do this. it is not in their benefit.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865159#respond' onclick='return addComment.moveForm( "comment-2865159", "2865159", "respond", "197224" )' aria-label='Reply to prophet for a profit'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
</ul><!-- .children -->
	<li id="comment-2865147" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Well-loved. Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865147" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865147', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865147-up" style="font-size:12px; color:#009933;">10</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865147" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865147', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865147-down" style="font-size:12px; color:#990033;">2</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://1.gravatar.com/avatar/45321f1b1e0e7db3fd41cdf213fae4a8?s=50&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/45321f1b1e0e7db3fd41cdf213fae4a8?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">wrong is wrong</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background:none !important"><p>Dominica is destroyed, yes my people, Da is badly destroyed and sadly, it&#8217;s not because of Erica of 2015 or Maria in 2017, but sadly because of the young man, who was a well known enenmy of the DLP, found a way to attend the funeral of Rosie and Pierro, before they could finish a term in office combined. Sadly that was the beginning of sorrow and destruction. From that time, a day after Pierre Charles was laid to rest, Dominica became a country of weeping and wailing, as everything our parents, teachers, and church taught us was wrong, somehow have become right under Skerrit, as Dominica continues to get deeper in trouble. So Linton doesn&#8217;t even have to blame Skerrit because we know that if it is something wrong and evil, Skerrit is the founder and designer of it. He wins by cheating in every damn thing. Look he is about to make Judas a minister, a minister he stole. In cricket when one is found paying to change the result of a game they are banned and finned. Not so with Skerrit</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865147#respond' onclick='return addComment.moveForm( "comment-2865147", "2865147", "respond", "197224" )' aria-label='Reply to wrong is wrong'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865146" class="comment odd alt thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Well-loved. Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865146" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865146', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865146-up" style="font-size:12px; color:#009933;">7</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865146" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865146', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865146-down" style="font-size:12px; color:#990033;">3</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/6cfc06ce3e45243afd70836502dc1a20?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/6cfc06ce3e45243afd70836502dc1a20?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">viewsexpressed</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background:none !important"><p>This man is a bigger joke than we expected &#8211; Read this nonsense: &#8220;Skerrit said when the DLP took a bill to parliament to do just what the opposition and others have been calling for, in terms of electoral reform, the parliament building and the police were stoned by protesters&#8230;.&#8221;<br />
Skerrit, shut up and stop making a royal fool of yourself. You have the power to call Parliament, when it suits you, you know what to do, and when it embarrasses you &#8211; you run away. Hypocritical behaviour we call this.<br />
Skerrit must Go&#8230;..Get out&#8230;Get Lost. You are not worth being our PM</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865146#respond' onclick='return addComment.moveForm( "comment-2865146", "2865146", "respond", "197224" )' aria-label='Reply to viewsexpressed'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865160" class="comment even depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865160" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865160', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865160-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865160" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865160', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865160-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/f28cae7c4ff8f59f86e6dd331828c161?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/f28cae7c4ff8f59f86e6dd331828c161?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">prophet for a profit</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>but they were not stoned. Supposedly there was a bag of stones behind dowasco they found. that was their reason for not doing it. Now, lets just say that is true, ANYONE can place a bag of stones anywhere. This is Dominica, coolwash is free. It could have been easily placed by a labor operative just easily as an opposition operative just to kaiboshe the passing of the bill. That was just an excuse not to.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865160#respond' onclick='return addComment.moveForm( "comment-2865160", "2865160", "respond", "197224" )' aria-label='Reply to prophet for a profit'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865202" class="comment odd alt depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865202" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865202', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865202-up" style="font-size:12px; color:#009933;">0</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865202" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865202', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865202-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Dominican to bone</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>He is ur p.m and that&#8217;s wat it is stop being bypass he is a Dominican and he ain&#8217;t goong know where and u know it so go and put ur head in a bag if u don&#8217;t want to see him .</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865202#respond' onclick='return addComment.moveForm( "comment-2865202", "2865202", "respond", "197224" )' aria-label='Reply to Dominican to bone'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
</ul><!-- .children -->
	<li id="comment-2865145" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865145" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865145', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865145-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865145" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865145', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865145-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/6461b64608240d25b8c2736fcdf962b1?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/6461b64608240d25b8c2736fcdf962b1?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">LifeandDeath</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>According to Simeon Albert would say..&#8221;is true!!&#8221;&#8230; <img src="http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif" alt=":lol:" class="wp-smiley" style="height: 1em; max-height: 1em;" />  <img src="http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif" alt=":lol:" class="wp-smiley" style="height: 1em; max-height: 1em;" /></p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865145#respond' onclick='return addComment.moveForm( "comment-2865145", "2865145", "respond", "197224" )' aria-label='Reply to LifeandDeath'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
	<li id="comment-2865144" class="comment odd alt thread-odd thread-alt depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Hot debate. What do you think? <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865144" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865144', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865144-up" style="font-size:12px; color:#009933;">3</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865144" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865144', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865144-down" style="font-size:12px; color:#990033;">9</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/394a5b82a8f59d2e77b284cb34fbbedc?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/394a5b82a8f59d2e77b284cb34fbbedc?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n"><a href='http://Yahoo' rel='external nofollow' class='url url'>Anon</a></span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background-color:#FFF0F5 !important"><p>Election reform has come to a standstill because of the attitude of the UWP. The UWP believes that only their ideas and that of their supporters must be considered in this matter. For electoral resort to happen there must be a meeting of the minds not this one track attitude of the opposition.</p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865144#respond' onclick='return addComment.moveForm( "comment-2865144", "2865144", "respond", "197224" )' aria-label='Reply to Anon'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865164" class="comment even depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865164" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865164', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865164-up" style="font-size:12px; color:#009933;">2</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865164" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865164', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865164-down" style="font-size:12px; color:#990033;">0</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/25950181bfb0c82354d87e0569b0a818?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/25950181bfb0c82354d87e0569b0a818?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Ibo France</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Anon, your remarks are quite chucklesome. Do you get paid for writing such ridiculousness? Even though you may be a Labor Party diehard, and that&#8217;s your inalienable right, don&#8217;t reduce yourself to a parasitic liar for crumbs from Skerrit&#8217;s bowl. It is blind and obdurate supporters like you who retard the progress of the country. Although this administration&#8217;s ill-advised policies have brought nothing but hopelessness and desolation to this country, the DLP is assuredly rewarded with your support. This is problematic for the development of the country.</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865164#respond' onclick='return addComment.moveForm( "comment-2865164", "2865164", "respond", "197224" )' aria-label='Reply to Ibo France'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865201" class="comment odd alt depth-3">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865201" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865201', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865201-up" style="font-size:12px; color:#009933;">0</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865201" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865201', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865201-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Dominican to bone</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>Stop defending Linton that went all over and tell lies about Dominica  this guy have know love for country.</p>
			</div>
			
			<div style="position: relative;">
							</div>
		</div>		
	</li>
</ul><!-- .children -->
</ul><!-- .children -->
	<li id="comment-2865142" class="comment even thread-even depth-1">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Well-loved. Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865142" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865142', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865142-up" style="font-size:12px; color:#009933;">9</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865142" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865142', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865142-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://0.gravatar.com/avatar/fe31ff7a555b21ce7c9ca647819f3199?s=50&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/fe31ff7a555b21ce7c9ca647819f3199?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Da passports</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<div style="background:none !important"><p>I blame DLP for everything, Rituals, Subway, Pizza hut game shops, movie theatre, crazy kokonuts and de kfc in portsmouth close down long before maria, all good ideas but they cannot stand under DLP is only skerrit and his lackies to make a dollar  <img src="http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif" alt=":roll:" class="wp-smiley" style="height: 1em; max-height: 1em;" />  <img src="http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif" alt=":roll:" class="wp-smiley" style="height: 1em; max-height: 1em;" /></p>
</div>			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865142#respond' onclick='return addComment.moveForm( "comment-2865142", "2865142", "respond", "197224" )' aria-label='Reply to Da passports'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
<ul class="children">
	<li id="comment-2865200" class="comment odd alt depth-2">
		<div class="comment-container clearfix">
			<div class="heading">
				<span class="rating">
					Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2865200" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2865200', 'add', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2865200-up" style="font-size:12px; color:#009933;">0</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2865200" src="http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2865200', 'subtract', 'http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2865200-down" style="font-size:12px; color:#990033;">1</span>					
				</span>	
				<a target='_blank' href='http://en.gravatar.com' title='Get Your Gravatar'><img alt='' src='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=50&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/81dfc19db1744668429fd150150c8316?s=100&#038;d=mm&#038;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>				 <span class="commenter fn n">Dominican to bone</span>				<span class="date_other">
					<span class="date">May 1, 2018</span>				</span>
							</div>
		
			<div class="comment-text">	               
				<p>To bad u cannot make y u to lazy .</p>
			</div>
			
			<div style="position: relative;">
				<span class="reply"><a rel='nofollow' class='comment-reply-link' href='http://dominicanewsonline.com/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?replytocom=2865200#respond' onclick='return addComment.moveForm( "comment-2865200", "2865200", "respond", "197224" )' aria-label='Reply to Dominican to bone'>Reply to this comment</a></span>			</div>
		</div>		
	</li>
</ul><!-- .children -->
				</ol>

				<!-- If there are enough comments, build the comment navigation -->
				                  

			</div> <!-- #comments-list .comments -->

		
		<!-- If there are trackbacks(pings), show the trackbacks -->
		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Post a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/homepage/news/politics/linton-blames-dlp-for-electoral-reform-standstill/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+DominicaNewsOnline+%28Dominica+News+Online%29#respond" style="display:none;">Cancel</a></small></h3>			<form action="http://dominicanewsonline.com/news/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span>.</p><p class="comment-form-comment"><label for="comment">Comment
	<!-- Custom Smilies - Version 2.9.2 -->
	<style type="text/css">
	img.wp-smiley-select {cursor: pointer;}
	</style>
    <script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
    function grin(tag) {
    	if (typeof tinyMCE != 'undefined') {
    		grin_tinymcecomments(tag);
    	} else {
    		grin_plain(tag);
    	}
    }
    function grin_tinymcecomments(tag) {
    	tinyMCE.execCommand('mceInsertContent', false, ' ' + tag + ' ');
    }
    
    function grin_plain(tag) {
    	var myField;
    	var myCommentTextarea = "comment";
    	tag = ' ' + tag + ' ';
        if (document.getElementById(myCommentTextarea) && document.getElementById(myCommentTextarea).type == 'textarea') {
    		myField = document.getElementById(myCommentTextarea);
    	} else {
    		return false;
    	}
    	if (document.selection) {
    		myField.focus();
    		sel = document.selection.createRange();
    		sel.text = tag;
    		myField.focus();
    	}
    	else if (myField.selectionStart || myField.selectionStart == '0') {
    		var startPos = myField.selectionStart;
    		var endPos = myField.selectionEnd;
    		var cursorPos = endPos;
    		myField.value = myField.value.substring(0, startPos)
    					  + tag
    					  + myField.value.substring(endPos, myField.value.length);
    		cursorPos += tag.length;
    		myField.focus();
    		myField.selectionStart = cursorPos;
    		myField.selectionEnd = cursorPos;
    	}
    	else {
    		myField.value += tag;
    		myField.focus();
    	}
    }
    
    function moreSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'inline';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:lessSmilies()">&laquo;&nbsp;less</a></span>';
    }
    
    function lessSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'none';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:moreSmilies()">more&nbsp;&raquo;</a>';
    }
    </script>
<img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_smile.gif' alt=':)' onclick='grin(":)")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_biggrin.gif' alt=':-D' onclick='grin(":-D")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_wink.gif' alt=':wink:' onclick='grin(":wink:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_sad.gif' alt=':(' onclick='grin(":(")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_eek.gif' alt='8-O' onclick='grin("8-O")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif' alt=':lol:' onclick='grin(":lol:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_neutral.gif' alt=':-|' onclick='grin(":-|")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cry.gif' alt=':cry:' onclick='grin(":cry:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cool.gif' alt='8)' onclick='grin("8)")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_confused.gif' alt=':-?' onclick='grin(":-?")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_razz.gif' alt=':-P' onclick='grin(":-P")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mad.gif' alt=':-x' onclick='grin(":-x")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_question.gif' alt=':?:' onclick='grin(":?:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_redface.gif' alt=':oops:' onclick='grin(":oops:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_twisted.gif' alt=':twisted:' onclick='grin(":twisted:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mrgreen.gif' alt=':mrgreen:' onclick='grin(":mrgreen:")' class='wp-smiley-select' /> <span id="wp-smiley-more" style="display:none"><img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif' alt=':roll:' onclick='grin(":roll:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_idea.gif' alt=':idea:' onclick='grin(":idea:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_evil.gif' alt=':evil:' onclick='grin(":evil:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_arrow.gif' alt=':arrow:' onclick='grin(":arrow:")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_surprised.gif' alt=':-o' onclick='grin(":-o")' class='wp-smiley-select' /> <img src='http://dominicanewsonline.com/news/wp-includes/images/smilies/icon_exclaim.gif' alt=':!:' onclick='grin(":!:")' class='wp-smiley-select' /> </span> <span id="wp-smiley-toggle"><a href="javascript:moreSmilies()">more&nbsp;&raquo;</a></span></label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"  onkeydown="gcllCounter(this)" onkeyup="gcllCounter(this)" ></textarea></p><span class="countdownbox">
<input readonly="readonly" type="text" id="commentlen" size="4" maxlength="4" value="1000" style="width:auto;text-indent:0;" />
&nbsp;characters available
</span><p class="comment-form-author"><label for="author">Name <span class="required">*</span> </label> <input id="author" name="author" type="text" value="" size="45" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span> </label> <input id="email" name="email" type="text" value="" size="45" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="45" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='197224' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3fd139256c" /></p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="228"/></p>			</form>
			</div><!-- #respond -->
	
</div> <!-- #comments -->
		</div>

	</div> <!-- #post -->	
		<!-- Load sidebar  -->
		
<div id="sidebar" class="sidebar">

	<!-- Static sidebar  -->
	
	<!-- Promo Side Banner -->
	
	<!-- Place Ezetop widget slot -->
					

	<!-- Related Posts -->
	 

			

			
		
	<!-- End of Static sidebar -->
	
	<!-- Dynamic sidebar -->
	<div id="administerwidget-56" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='administer-ad-17' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=250&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/04/FFIKFC_Mom__Me_306x250.jpeg' style='width: 306px; height: 250px; ' width='306' height='250'   /></div></div></div><div id="administerwidget-48" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='administer-ad-20' class='administer-ad'><a id='administer-adlink-20' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_20=http%3A%2F%2Fwww.archip.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Right (Distribution)'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/03/Archipelago-Mar-9.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="administerwidget-47" class="widget widget_administerwidget"><div  data-timeout='10000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='administer-ad-6' class='administer-ad'><a id='administer-adlink-6' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_6=http%3A%2F%2Fdhta.org%2Ftalking-tourism%2F2018%2F04%2F20%2Fhikefest-registration-form%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'DHTA Hike Fest 2018 - Article'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=250&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/04/HikeFest306GIF.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div><div id='administer-ad-4' class='administer-ad'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/04/AidBankApril-GIF.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></div></div></div><div id="tribe-events-list-widget-3" class="widget tribe-events-list-widget"><h2 class="widgettitle">Upcoming Events</h2>

	<ol class="tribe-list-widget">
					<li class="tribe-events-list-widget-events type-tribe_events post-196616 tribe-clearfix tribe-events-venue-196621 tribe-events-organizer-196622 tribe-event-featured">
									<div class="tribe-event-image">
						<a href="http://dominicanewsonline.com/news/event/domfesta-programme-2018/"><img width="306" height="250" src="http://dominicanewsonline.com/news/wp-content/uploads/2018/04/domfesta306.gif" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>					</div>
					
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://dominicanewsonline.com/news/event/domfesta-programme-2018/" rel="bookmark">DOMFESTA Programme 2018</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">April 14 @ 5:00 pm</span> - <span class="tribe-event-date-end">June 2 @ 8:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-196789 tribe-clearfix tribe-events-venue-196794 tribe-events-organizer-196785 tribe-event-featured">
									<div class="tribe-event-image">
						<a href="http://dominicanewsonline.com/news/event/hike-fest-2018/"><img width="306" height="250" src="http://dominicanewsonline.com/news/wp-content/uploads/2018/04/hikefest306-1.gif" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>					</div>
					
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://dominicanewsonline.com/news/event/hike-fest-2018/" rel="bookmark">Hike Fest 2018</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 5 @ 5:30 am</span> - <span class="tribe-event-date-end">May 26 @ 12:00 am</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-196629 tribe-clearfix tribe-events-venue-196633 tribe-event-featured">
									<div class="tribe-event-image">
						<a href="http://dominicanewsonline.com/news/event/sweet-mothers-day-kaiso-punch-and-party/"><img width="306" height="250" src="http://dominicanewsonline.com/news/wp-content/uploads/2018/04/kaiso306.gif" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>					</div>
					
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://dominicanewsonline.com/news/event/sweet-mothers-day-kaiso-punch-and-party/" rel="bookmark">Sweet Mother&#8217;s Day Kaiso Punch and Party</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 13 @ 6:00 pm</span> - <span class="tribe-event-time">12:00 am</span>				</div>

							</li>
			</ol><!-- .tribe-list-widget -->

	<p class="tribe-events-widget-link">
		<a href="http://dominicanewsonline.com/news/events/" rel="bookmark">View All Events</a>
	</p>

</div><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"DOMFESTA Programme 2018","description":"","image":"http://dominicanewsonline.com/news/wp-content/uploads/2018/04/domfesta306.gif","url":"http://dominicanewsonline.com/news/event/domfesta-programme-2018/","startDate":"2018-04-14T17:00:00-04:00","endDate":"2018-06-02T20:00:00-04:00","location":{"@type":"Place","name":"Multiple venues","description":"","url":false,"address":{"@type":"PostalAddress","addressCountry":"Dominica"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"Division of Culture","description":"","url":false,"telephone":"","email":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Hike Fest 2018","description":"","image":"http://dominicanewsonline.com/news/wp-content/uploads/2018/04/hikefest306-1.gif","url":"http://dominicanewsonline.com/news/event/hike-fest-2018/","startDate":"2018-05-05T05:30:00-04:00","endDate":"2018-05-26T00:00:00-04:00","location":{"@type":"Place","name":"PrevoCinemall","description":"","url":false,"address":{"@type":"PostalAddress","streetAddress":"Cnr. of Old Street &amp; Kennedy Avenue","addressLocality":"Roseau","addressCountry":"Dominica"},"telephone":"7674405750","sameAs":"http://www.prevocinemall.com/"},"organizer":{"@type":"Person","name":"Dominica Hotel and Tourism Association","description":"","url":false,"telephone":"(767) 275-7453/ 440-3430","email":"&#105;&#110;f&#111;&#64;d&#104;&#116;a&#46;o&#114;&#103;","sameAs":"http://dhta.org/"},"offers":{"@type":"Offer","price":"25 - 50","url":"http://dominicanewsonline.com/news/event/hike-fest-2018/"}},{"@context":"http://schema.org","@type":"Event","name":"Sweet Mother&#8217;s Day Kaiso Punch and Party","description":"","image":"http://dominicanewsonline.com/news/wp-content/uploads/2018/04/kaiso306.gif","url":"http://dominicanewsonline.com/news/event/sweet-mothers-day-kaiso-punch-and-party/","startDate":"2018-05-13T18:00:00-04:00","endDate":"2018-05-14T00:00:00-04:00","location":{"@type":"Place","name":"The Strip (Lalay Coco) Loubiere","description":"","url":false,"address":{"@type":"PostalAddress","streetAddress":"Lalay Coco","addressLocality":"Loubiere","addressCountry":"Dominica"},"telephone":"","sameAs":""},"offers":{"@type":"Offer","price":"20","url":"http://dominicanewsonline.com/news/event/sweet-mothers-day-kaiso-punch-and-party/"}}]
</script><div id="administerwidget-42" class="widget widget_administerwidget"><div  class=' first-ad administer-ad-container'><div id='administer-ad-63' class='administer-ad'><a id='administer-adlink-63' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_63=http%3A%2F%2Fwww.ndfd.dm%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NDFD- Home &amp; Article Side'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2018/04/NDFD-April.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="administerwidget-43" class="widget widget_administerwidget"><div  data-timeout='15000' data-fx='scroll' class=' tcycle administer-ad-container'><div id='administer-ad-175' class='administer-ad'><a id='administer-adlink-175' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_175=http%3A%2F%2Flife101radio.net%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Life101Radio'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=306&amp;h=250&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2017/03/Life101306x250.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div><div id='administer-ad-80' class='administer-ad'><a id='administer-adlink-80' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_80=http%3A%2F%2Fwww.crimestoppersdominica.org' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Crime Stoppers'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/uploads/2017/03/CrimeStoppersMar10.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></a></div></div></div><div id="polls-widget-3" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<p>Sorry, there are no polls available at the moment.</p></div>
</div> <!-- .siderbar -->	</div>

	<div  class='margin-banner-left first-ad administer-ad-container'><div id='administer-ad-2' class='administer-ad'><a id='administer-adlink-2' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_2=https%3A%2F%2Fwww.buymozlems.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Universal Elegance Article Margin Left'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=100&amp;h=651&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/04/Universal-Elegance-April-27.png' style='width: 100px; height: 651px; ' width='100' height='651'   /></a></div></div><div  class='margin-banner-right first-ad administer-ad-container'><div id='administer-ad-3' class='administer-ad'><a id='administer-adlink-3' class=''   href='http://dominicanewsonline.com/news/?administer_redirect_3=https%3A%2F%2Fwww.buymozlems.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Universal Elegance Article Margin Right'); }"  target='_blank' rel='nofollow'><img class='administer-lazy-load' data-src='http://dominicanewsonline.com/news/wp-content/plugins/ad-minister/script/timthumb/timthumb.php?q=70&amp;w=100&amp;h=651&amp;zc=0&amp;src=http://dominicanewsonline.com/news/wp-content/uploads/2018/04/Universal-Elegance-April-16.png' style='width: 100px; height: 651px; ' width='100' height='651'   /></a></div></div>	
			<!-- FOOTER  -->
							<div id="footer" class="container">	
					<div class="footer-content">
						<!-- 'Back To Top' button -->
						<span class="back_to_top"><a title="Go to the top of the page" href="javascript:void(0)" onclick="jQuery(window).scrollTop(0); return false;"><i class="fa fa-arrow-circle-o-up fa-3x"></i><!-- Back To Top--></a></span>
						
						<!-- Social Links -->
						<div id="footerFollow" class="clearfix">
							<h3>Follow Us</h3>
							<ul>
								<li class="SubscribeLink"><a target="_blank" title="Subscribe to RSS Feed" href="http://feeds.feedburner.com/DominicaNewsOnline/"></a></li>
								<li class="FacebookLink"><a target="_blank" title="Follow us on Facebook" href="http://www.facebook.com/DominicaNewsOnline"></a></li>
								<li class="TwitterLink"><a target="_blank" title="Follow us on Twitter" href="https://twitter.com/#!/DNONews"></a></li>
							</ul>
						</div> <!-- #footerFollow -->				
						
						<!-- Legal Information -->
						<div class="footer-links">
							<a href="http://dominicanewsonline.com/news/policies/#privacy">Privacy Policy</a>
							<a href="http://dominicanewsonline.com/news/policies/#disclaimers">Disclaimers</a>
							<a href="http://dominicanewsonline.com/news/policies/#comment-policy">Comment Policy</a>
							<a href="http://dominicanewsonline.com/news/policies/#faq">Frequently Asked Questions</a>
							<a href="http://dominicanewsonline.com/news/contact/">Contact Us</a>
						</div>
						<p><a href="http://dominicanewsonline.com/news/policies/#copyright">Copyright &#169; 2007-2018</a> Dominica News Online, Duravision Inc &#8226; Roseau, Dominica &#8226; All rights reserved.</p>				
					</div> <!-- #footer-content -->							
				</div> <!-- #footer -->
			<script type="text/javascript">
// <![CDATA[
// ]]>
</script>
<!-- Start Of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type="text/javascript">
<!--
function gcllCounter(textarea) {
if (textarea.value.length > 1000)
textarea.value = textarea.value.substring(0, 1000);
else
document.getElementById('commentlen').value = 1000 - textarea.value.length;
}
//-->
</script>
<!-- End of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='71bb7f91eaa80a7e8f49c6fa8a8bf7e8';
hf4V='d29301cfc77a27ebbe2184387a98cd22';
cm4S="form[action='http://dominicanewsonline.com/news/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
				<!-- Java SDK script for Facebook 'Like' button -->
		<div id="fb-root"></div>
		<script type="text/javascript" language="javascript">
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=246787465390190";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		</script>

		<!-- Script for Twitter 'follow' button -->
		<script type="text/javascript" language="javascript">
		!function(d,s,id){
			var js,fjs=d.getElementsByTagName(s)[0];
			if(!d.getElementById(id)){
				js=d.createElement(s);
				js.id=id;js.src="//platform.twitter.com/widgets.js";
				fjs.parentNode.insertBefore(js,fjs);
			}
		}(document,"script","twitter-wjs");
		</script>
	<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/comment-rating/ck-karma.js' defer '></script>
<script type='text/javascript' src='//dominicanewsonline.com/news/wp-content/plugins/connections/vendor/picturefill/picturefill.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-polls/polls-js.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/comment-reply.min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/js/jquery.colorbox.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/js/jquery.tooltip.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/lightbox-gallery/lightbox-gallery.js' defer '></script>
<script type='text/javascript' src='http://dominicanewsonline.com/news/wp-includes/js/wp-embed.min.js' defer '></script>
<script async="async" type='text/javascript' src='http://dominicanewsonline.com/news/wp-content/plugins/akismet/_inc/form.js' defer '></script>
		</div> <!-- #page-wrapper -->
	</body>
</html>
