<!DOCTYPE html><html lang="en-US"><head><meta http-equiv="x-ua-compatible" content="ie=edge"><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><meta name="google-site-verification" content="bBuHZdxdwW3W8iMT758WT6N3fo38yHZ-87h4XzOMyXw" /> <script data-ad-client="ca-pub-6732730031512336" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><link media="all" href="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/css/autoptimize_77b2d133cafb9829114a442683a7c0a5.css" rel="stylesheet" /><link media="screen" href="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/css/autoptimize_919be5d5dc481ff3d503e14e080e867c.css" rel="stylesheet" /><title>Grand Bay man charged with firearm &amp; ammunition offences denied bail; Belvue Chopin man pleads guilty to importation of ammunition - Dominica News Online</title><link rel="canonical" href="https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Grand Bay man charged with firearm &amp; ammunition offences denied bail; Belvue Chopin man pleads guilty to importation of ammunition - Dominica News Online" /><meta property="og:description" content="A Grand Bay man has been denied bail and is now remanded in custody at the Dominica State Prison after the police brought several charges against him for the importation and trafficking of firearms and ammunition. On February 3, 2022,..." /><meta property="og:url" content="https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/" /><meta property="og:site_name" content="Dominica News Online" /><meta property="article:published_time" content="2022-02-11T17:35:09+00:00" /><meta property="article:modified_time" content="2022-02-12T14:15:44+00:00" /><meta property="og:image" content="https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="933" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Admin" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="4 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dominicanewsonline.com/news/#website","url":"https://dominicanewsonline.com/news/","name":"Dominica News Online","description":"The most popular news site in the Commonwealth of Dominica","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dominicanewsonline.com/news/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#primaryimage","inLanguage":"en-US","url":"https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port.jpg","contentUrl":"https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port.jpg","width":1920,"height":933,"caption":"The 15 firearms which were seized"},{"@type":"WebPage","@id":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#webpage","url":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/","name":"Grand Bay man charged with firearm & ammunition offences denied bail; Belvue Chopin man pleads guilty to importation of ammunition - Dominica News Online","isPartOf":{"@id":"https://dominicanewsonline.com/news/#website"},"primaryImageOfPage":{"@id":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#primaryimage"},"datePublished":"2022-02-11T17:35:09+00:00","dateModified":"2022-02-12T14:15:44+00:00","author":{"@id":"https://dominicanewsonline.com/news/#/schema/person/1cf13c57fb23f5f3f17888628ce87bed"},"breadcrumb":{"@id":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/"]}]},{"@type":"BreadcrumbList","@id":"https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dominicanewsonline.com/news/"},{"@type":"ListItem","position":2,"name":"Grand Bay man charged with firearm &#038; ammunition offences denied bail; Belvue Chopin man pleads guilty to importation of ammunition"}]},{"@type":"Person","@id":"https://dominicanewsonline.com/news/#/schema/person/1cf13c57fb23f5f3f17888628ce87bed","name":"Admin","image":{"@type":"ImageObject","@id":"https://dominicanewsonline.com/news/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68732e6ad6cd39603a4ac10588629490?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/68732e6ad6cd39603a4ac10588629490?s=96&d=mm&r=g","caption":"Admin"},"url":"https://dominicanewsonline.com/news/author/tdurand/"}]}</script> <link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="text/calendar" title="Dominica News Online &raquo; iCal Feed" href="https://dominicanewsonline.com/news/events/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dominicanewsonline.com\/news\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='awpcp-font-awesome-css' href='https://use.fontawesome.com/releases/v5.2.0/css/all.css' type='text/css' media='all' /> <!--[if lte IE 6]><link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' type='text/css' media='all' /> <![endif]--> <!--[if lte IE 7]><link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' type='text/css' media='all' /> <![endif]--> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/dominicanewsonline.com\/news\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/dominicanewsonline.com\/news\/wp-json\/wordpress-popular-posts","ID":280914,"token":"f5631af1eb","lang":0,"debug":0}</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-content/cache/autoptimize/js/autoptimize_single_9ffdba2cff497d701684657e329871f5.js' id='swfobject-js'></script> <link rel="https://api.w.org/" href="https://dominicanewsonline.com/news/wp-json/" /><link rel="alternate" type="application/json" href="https://dominicanewsonline.com/news/wp-json/wp/v2/posts/280914" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dominicanewsonline.com/news/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dominicanewsonline.com/news/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://dominicanewsonline.com/news/?p=280914' /><link rel="alternate" type="application/json+oembed" href="https://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F" /><link rel="alternate" type="text/xml+oembed" href="https://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F&#038;format=xml" /> <noscript><style>.ad-minister-ad img.lazyload { display: none; }</style></noscript> <script type="text/javascript" language="javascript">(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-28491038-1', 'auto');
			ga('set', 'contentGroup1', 'Articles');
			ga('send', 'pageview');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=G-MWJR60HYW5"></script> <script>window.dataLayer = window.dataLayer || [];
			function gtag(){dataLayer.push(arguments);}
			gtag('js', new Date());

			gtag('config', 'G-MWJR60HYW5');</script> <script type="text/javascript">function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}</script> <link rel="manifest" href="https://dominicanewsonline.com/news/wp-json/wp/v2/web-app-manifest"><meta name="theme-color" content="#ffffff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Dominica News Online"><meta name="application-name" content="Dominica News Online"><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dominicanewsonline.com/news"><link rel="alternate" href="https://dominicanewsonline.com/news/wp-json/tribe/events/v1/" /><link rel="pingback" href="https://dominicanewsonline.com/news/xmlrpc.php"><link rel="canonical" href="https://dominicanewsonline.com/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/" /> <!--[if IE 9]><link href="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/css/bootstrap-ie9.min.css" rel="stylesheet"> <![endif]--> <!--[if lte IE 8]><link href="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/css/bootstrap-ie8.min.css" rel="stylesheet"> <script src="https://cdn.jsdelivr.net/g/html5shiv@3.7.3"></script> <![endif]--> <!--[if gte IE 9]> <script src="https://code.jquery.com/jquery-3.3.1.slim.min.js"></script> <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.6/umd/popper.min.js"></script> <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.min.js"></script> <![endif]--> <!--[if IE 9]> <script src="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/js/bootstrap-ie9.min.js"></script> <![endif]--> <!--[if lte IE 8]> <script src="https://code.jquery.com/jquery-1.12.4.min.js"></script> <script src="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/js/bootstrap-ie8.min.js"></script> <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.js"></script> <![endif]--> <script async src="https://powerad.ai/92906088025000/script.js"></script> <script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body data-rsssl=1 class="post-template-default single single-post postid-280914 single-format-standard tribe-no-js no-sidebar"><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><div class="container page-container"><div class="row"><div class="main-col col-12 col-sm-12 no-margin-banner"><header id="masthead" class="site-header"><div class="row no-gutters clearfix"><div class="col-md-4"><div class="logo-container"><div class="logo"> <a href="https://dominicanewsonline.com/news"> <img alt="Dominica News Online | Independent. Immediate. Trusted." src="https://dominicanewsonline.com/news/wp-content/themes/dnobootstrap/images/DNO-Logo.png" /> </a></div><div class="social-buttons" id="social-buttons"><div class="social-button"><div class="fb-like" data-href="https://www.facebook.com/DominicaNewsOnline" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false"></div></div><div class="social-button"> <a class="twitter-follow-button" href="https://twitter.com/DNONews" data-show-count="false" data-show-screen-name="false">Follow @DNONews</a></div></div></div></div><div class="col-md-8"><div class="logo-banner-wrapper clearfix"><div data-timeout='15000' data-fx='scroll' class='logoBanner tcycle administer-ad-container'><div id='administer-ad-136' class='administer-ad'><a id='administer-adlink-136' class='' href='https://dominicanewsonline.com/news/?administer_redirect_136=http%3A%2F%2Fwww.nccudominica.com%2FLoans%2FCash-Secured-Loans.html' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NCCU Article Menu Banner - Online services'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/DNO-4.5-ASAP.png' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/DNO-4.5-ASAP.png' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div><div id='administer-ad-25' class='administer-ad'><a id='administer-adlink-25' class='' href='https://dominicanewsonline.com/news/?administer_redirect_25=https%3A%2F%2Fsecure.moneygram.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Logo (Money Gram)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/12/money-gram_AMERICAS-Holiday-digital-campaign-2020_642x140px_Eng.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/12/money-gram_AMERICAS-Holiday-digital-campaign-2020_642x140px_Eng.jpg' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div></div></div></div><nav class="navbar navbar-expand-lg navbar-dark clearfix" role="navigation"> <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-menu-main" aria-controls="navbar-menu-main" aria-expanded="false" aria-label="Toggle navigation"> <span class="navbar-toggler-icon"></span> </button><div id="navbar-menu-main" class="mx-auto collapse navbar-collapse"><ul id="menu-main-menu" class="navbar-nav mx-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-60267 nav-item"><a title="Home" href="https://dominicanewsonline.com/news/" class="nav-link"><i class="fa fa-home"></i> Home</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-216822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-216822 nav-item"><a title="Categories" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link" id="menu-item-dropdown-216822">Categories</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-216822" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-252735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252735 nav-item"><a title="Historical" href="https://dominicanewsonline.com/news/category/homepage/news/historical/" class="dropdown-item">Historical</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109591" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent active menu-item-109591 nav-item"><a title="News" href="https://dominicanewsonline.com/news/category/homepage/news/" class="dropdown-item">News</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109606 nav-item"><a title="Announcements" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109606">Announcements</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109606" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-141462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141462 nav-item"><a title="Death Announcements" href="https://dominicanewsonline.com/news/category/announcements/death-announcements/" class="dropdown-item">Death Announcements</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-141463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141463 nav-item"><a title="General Announcements" href="https://dominicanewsonline.com/news/category/announcements/general-announcements/" class="dropdown-item">General Announcements</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109592 nav-item"><a title="Columns" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109592">Columns</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109592" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109593 nav-item"><a title="Alive Word" href="https://dominicanewsonline.com/news/category/homepage/columns/alive-word/" class="dropdown-item">Alive Word</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109594 nav-item"><a title="CariMAN" href="https://dominicanewsonline.com/news/category/homepage/columns/cariman/" class="dropdown-item">CariMAN</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109595 nav-item"><a title="Dear Bella" href="https://dominicanewsonline.com/news/category/homepage/columns/dear-bella/" class="dropdown-item">Dear Bella</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109596 nav-item"><a title="Ghost Stories" href="https://dominicanewsonline.com/news/category/homepage/columns/ghost-stories/" class="dropdown-item">Ghost Stories</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109597 nav-item"><a title="Health Talk" href="https://dominicanewsonline.com/news/category/homepage/columns/health-talk/" class="dropdown-item">Health Talk</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109598 nav-item"><a title="Just Dennis" href="https://dominicanewsonline.com/news/category/homepage/columns/just-dennis/" class="dropdown-item">Just Dennis</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109599 nav-item"><a title="Natural Healing" href="https://dominicanewsonline.com/news/category/homepage/columns/natural-healing/" class="dropdown-item">Natural Healing</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109600 nav-item"><a title="Stay Well &amp; Sparkle!" href="https://dominicanewsonline.com/news/category/homepage/columns/stay-well-sparkle/" class="dropdown-item">Stay Well &amp; Sparkle!</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109601 nav-item"><a title="Features" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109601">Features</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109601" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109602 nav-item"><a title="Business In Focus" href="https://dominicanewsonline.com/news/category/homepage/features/business-features/" class="dropdown-item">Business In Focus</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109603 nav-item"><a title="Check This Out" href="https://dominicanewsonline.com/news/category/homepage/features/check-this-out/" class="dropdown-item">Check This Out</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109604 nav-item"><a title="Commentary" href="https://dominicanewsonline.com/news/category/homepage/features/commentary/" class="dropdown-item">Commentary</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109605 nav-item"><a title="Letters to the Editor" href="https://dominicanewsonline.com/news/category/homepage/features/letters-to-the-editor/" class="dropdown-item">Letters to the Editor</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-251939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251939 nav-item"><a title="Featured Photo" href="https://dominicanewsonline.com/news/category/homepage/features/featured-photo/" class="dropdown-item">Featured Photo</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109608 nav-item"><a title="Poetry Corner" href="https://dominicanewsonline.com/news/category/homepage/features/poetry/" class="dropdown-item">Poetry Corner</a></li></ul></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-87503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87503 nav-item"><a title="Business Directory" href="https://dominicanewsonline.com/news/business-directory/" class="nav-link">Business Directory</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60279 nav-item"><a title="Classifieds" href="https://dominicanewsonline.com/news/classifieds/" class="nav-link">Classifieds</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-157540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157540 nav-item"><a title="Events" href="https://dominicanewsonline.com/news/events/" class="nav-link">Events</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60280 nav-item"><a title="Contact Us" href="https://dominicanewsonline.com/news/contact/" class="nav-link">Contact Us</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-64197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64197 nav-item"><a title="News Links" href="https://dominicanewsonline.com/news/news-links/" class="nav-link">News Links</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-265770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-265770 nav-item"><a title="Combatting COVID-19" href="https://dominicanewsonline.com/news/combatting-covid-19/" class="nav-link">Combatting COVID-19</a></li></ul></div></nav><div class="menu-banner-wrapper clearfix"><div class='menu-banner-left first-ad administer-ad-container'><div id='administer-ad-95' class='administer-ad'><a id='administer-adlink-95' class='' href='https://dominicanewsonline.com/news/?administer_redirect_95=http%3A%2F%2Fwww.kfcdominica.com' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'FFI KFC GENIUS + Catch of The day (2) - Home Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/KFC_DOM-DNO.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/KFC_DOM-DNO.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div><div class='menu-banner-right first-ad administer-ad-container'><div id='administer-ad-405' class='administer-ad'><a id='administer-adlink-405' class='' href='https://dominicanewsonline.com/news/?administer_redirect_405=https%3A%2F%2Fwww.aa.com%2Fen-us%2Fflights-to-dominica' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'DDA American Airlines Article Menu (originally home logo)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/AA-Flight-DNO-Ad-Final.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/AA-Flight-DNO-Ad-Final.jpg' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div></div><div id="toolBar" class="toolbar row no-gutters clearfix"><div class="col-sm-4 col-md-3"><div class="toolBarButtons clearfix"><div class="social-links row no-gutters"><div class="col"> <a class="social-link social-rss" target="_blank" title="Subscribe to our RSS Feed" href="https://feeds.feedburner.com/DominicaNewsOnline/"><i class="fas fa-rss-square fa-2x"></i></a></div><div class="col"> <a class="social-link social-facebook" target="_blank" title="Follow us on Facebook" href="https://www.facebook.com/DominicaNewsOnline"><i class="fab fa-facebook fa-2x"></i></a></div><div class="col"> <a class="social-link social-twitter" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"><i class="fab fa-twitter-square fa-2x"></i></a></div><div class="col"> <a class="social-link social-instagram" target="_blank" title="Follow us on Instagram" href="https://www.instagram.com/dominicanewsonline"><i class="fab fa-instagram fa-2x"></i></a></div></div></div></div><div class="col-sm-8 col-md-6"><div id="ticker" class="ticker"><div class="marquee">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</div></div></div><div class="col-md-3"><form id="searchBar" class="row no-gutters" name="searchBar" method="get" action="https://dominicanewsonline.com/news"><div class="input-group"> <input id="searchField" class="form-control" type="search" name="s" placeholder="Search..." value=""> <input id="searchButton" type="button" title="Search" value=" "></div></form></div></div></header><div id="content" class="site-content"><div class="row"><div id="primary-wrapper" class="col-md-8 col-sm-7"><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-280914" class="clearfix post-280914 post type-post status-publish format-standard has-post-thumbnail hentry category-crime-court-law category-homepage-carousel category-news"><div data-timeout='15000' data-fx='scroll' class='contentBanner tcycle administer-ad-container'><div id='administer-ad-82' class='administer-ad'><a id='administer-adlink-82' class='' href='https://dominicanewsonline.com/news/?administer_redirect_82=https%3A%2F%2Fspringbel.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Springfield Trading - Article Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2019/10/springfield-trading-oct.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2019/10/springfield-trading-oct.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div><div id='administer-ad-263' class='administer-ad'><a id='administer-adlink-263' class='' href='https://dominicanewsonline.com/news/?administer_redirect_263=https%3A%2F%2Fwww.campbells-art.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Campbell's Business Machines (Banners, Posters, Signs) Article Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/09/Campbells-Banner-Gif.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/09/Campbells-Banner-Gif.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div><nav class='breadcrumb'><a href="https://dominicanewsonline.com/news/" alt='Home' title='Home'>Home</a><span class='divider'>&nbsp;&gt;&gt;&nbsp;</span><a href='https://dominicanewsonline.com/news/category/homepage/news/' title='News'>News</a></nav><header class="entry-header"><h1 class="entry-title">Grand Bay man charged with firearm &#038; ammunition offences denied bail; Belvue Chopin man pleads guilty to importation of ammunition</h1><div class="entry-meta"> <strong>Dominica News Online - </strong>Friday, February 11th, 2022 at 1:35 PM</div></header><div class="entry-content"><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="none" data-float-mobile="none" data-transition="slide" data-post-id="280914"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Grand+Bay+man+charged+with+firearm+%26+ammunition+offences+denied+bail%3B+Belvue+Chopin+man+pleads+guilty+to+importation+of+ammunition&url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F" data-link="https://twitter.com/intent/tweet?text=Grand+Bay+man+charged+with+firearm+%26+ammunition+offences+denied+bail%3B+Belvue+Chopin+man+pleads+guilty+to+importation+of+ammunition&url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fgrand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
 e.setAttribute('type','text/javascript');
 e.setAttribute('charset','UTF-8');
 e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
 document.body.appendChild(e);
 "><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div></div><figure id="attachment_280787" aria-describedby="caption-attachment-280787" style="width: 640px" class="wp-caption aligncenter"><img class="size-large wp-image-280787" src="https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-642x312.jpg" alt="" width="640" height="311" srcset="https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-642x312.jpg 642w, https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-300x146.jpg 300w, https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-768x373.jpg 768w, https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-1536x746.jpg 1536w, https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port-640x311.jpg 640w, https://dominicanewsonline.com/news/wp-content/uploads/2022/02/Firearms-at-port.jpg 1920w" sizes="(max-width: 640px) 100vw, 640px" /><figcaption id="caption-attachment-280787" class="wp-caption-text">The 15 firearms which were seized</figcaption></figure><p>A Grand Bay man has been denied bail and is now remanded in custody at the Dominica State Prison after the police brought several charges against him for the importation and trafficking of firearms and ammunition.</p><p>On February 3, 2022, at the Woodbridge Bay Port in Fond Cole, fifteen firearms, 12 magazines and 964 live rounds of ammunition hidden in several items in a cargo container on the port <a href="https://dominicanewsonline.com/news/homepage/homepage-carousel/guns-discovered-at-the-port-one-man-in-police-custody/">were recovered by members of the Customs and Excise division </a>during a routine check at the Port.</p><p>Jade Stewart of Lalay Grand Bay has since been slapped with several charges and appeared before Magistrate Gloria Augustus Thursday February 10, 2022, where the charges were read to him.</p><p>It is alleged that on February 3, 2022, at the Woodbridge Bay Port in Fond Cole, Stewart engaged in the unlawful trafficking of 15 firearms and 964 rounds of ammunition.</p><p>He was not required to enter a plea since the offence is an indictable one.</p><p>The police preferred 15 charges of importation of the said firearms and three charges of importation of the several rounds of ammunition into Dominica against the accused as he is not the holder of a firearms import license.</p><p>Stewart elected to have a summary trial for the importation charges at the magistrate’s court and pleaded not guilty to the offenses.</p><p>At the hearing, Police Prosecutor Inspector Davidson Cadette, objected to bail based on the Bail Act number 20 of 2020, citing section 4 subsection 3 for his reason.</p><p>According to Cadette, based on this section of the law, the accused is not entitled to bail as a right and added that this is further strengthened by section 7:1 (D) under the firearm act.</p><p>Inspector Cadette further posited, given the prevalence of firearms and ammunition offenses in Dominica in recent times, there is grave public interest in this matter.</p><p>He further argued that due to the serious nature of the offense and the penalty which will be applied if the defendant is found guilty, Stewart poses as a flight risk and may attempt to abscond justice.</p><p>The police prosecutor also pleaded with the court to deny bail on the ground that the police  are conducting a parallel investigation against Stewart and fears that he may interfere with documentary evidence and witnesses if released.</p><p>In a brief response to the prosecution&#8217;s objection, attorney-at-law Zena Dyer of the law firm of Dyer &amp; Dyer, argued that the prosecution had failed to give any grounds in accordance with the bail act to establish that bail should be withheld from her client, and as such she said bail should be granted.</p><p>However, in handing down her decision, Magistrate Augustus said based on the argument of the prosecution, she had agreed to the grounds put forward and denied bail to the accused.</p><p>Dyer immediately indicated her intention to move to the High Court to seek bail for her client and requested from the Magistrate, based on section 14 (1) of the Bail Act, her reason in writing for her denial of bail to proceed.</p><p>The matter was adjourned to June 17, 2022.</p><p>Meanwhile, Kent Thomas Mitchell of Bellevue Chopin was also charged with trafficking and importation of ammunition.</p><p>According to the charges preferred, it is alleged that on February 7, 2022, at the Woodbridge Bay Port in Fond Cole, Mitchell engaged in the unlawful trafficking of 150 9mm live rounds of  ammunition.</p><p>He was not required to enter a plea for this charge since it is an indictable offense.</p><p>For the second charge of importation of 150 9mm live rounds of ammunition, Mitchell opted for a summary trial in the magistrate court and pleaded guilty to the charge.</p><p>Presiding Magistrate Augusutus adjourned the matter to February 11, 2022, for facts and sentencing.</p><p>The prosecution then made an application pursuant to section 212 of the Magistrate Code of Procedure to have the accused placed in the custody of the investigating officer until his return to court.</p><p>Mitchell is represented by attorney-at-law Wayne Norde.</p><div class="swp-content-locator"></div></div><footer class="entry-footer"><div class="post-copyright"><p> Copyright 2012 Dominica News Online, DURAVISION INC. All Rights Reserved. This material may not be published, broadcast, rewritten or distributed.</p></div><div class='contentBanner first-ad administer-ad-container'><div id='administer-ad-407' class='administer-ad'><video id='mp4ad407' width='' height='' autoplay loop muted playsinline preload='none' style='vertical-align: middle;'> <source src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4' type='video/mp4' /> <object classid='clsid:02bf25d5-8c17-4b23-bc80-d3488abddc6b' codebase='http://www.apple.com/qtactivex/qtplugin.cab' width='' height='' type='application/x-shockwave-flash' data='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4'><param name='src' value='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4' /><param name='movie' value='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4' /><param name='flashvars' value='file=https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4' /><param name='autoplay' value='true' /><param name='loop' value='true' /><param name='mute' value='true' /><param name='controls' value='false' /> <embed src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/natures-discount-high-quality.mp4' type='image/x-macpaint' pluginspage='http://www.apple.com/quicktime/download' width='' height='' autoplay='true' loop='true' mute='true'></embed> </object></video><a id='administer-adlink-407' class='block-content-link' href='https://dominicanewsonline.com/news/?administer_redirect_407=https%3A%2F%2Fwww.facebook.com%2Fnaturesdicountdca' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Nature's Discount package article '); }" target='_blank' rel='nofollow, noindex'></a></div></div><div class="widget-bar row"><div class="col-md-6"><div id="relatedPosts" class="widget"><h3 class="widget-title">Related Articles</h3><div class="newsItems"><ul><ul><li><a href="https://dominicanewsonline.com/news/homepage/news/canefield-men-charged-with-possession-of-several-firearms-multiple-rounds-of-ammunition-and-drug-trafficking/" rel="bookmark" title="March 2, 2021">Canefield men charged with possession of several firearms, multiple rounds of ammunition and drug trafficking</a></li><li><a href="https://dominicanewsonline.com/news/homepage/homepage-carousel/calibishie-man-denied-bail-for-possession-of-ammunition/" rel="bookmark" title="March 24, 2021">Calibishie man denied bail for possession of ammunition</a></li><li><a href="https://dominicanewsonline.com/news/homepage/homepage-carousel/grand-bay-man-denied-bail-after-being-charged-with-possession-of-live-ammunition/" rel="bookmark" title="March 18, 2021">Grand Bay man denied bail after being charged with possession of live ammunition</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/crime-court-law/alleged-western-union-robbers-denied-bail-remanded/" rel="bookmark" title="February 7, 2012">Alleged Western Union robbers denied bail; remanded</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/crime-court-law/grand-bay-man-pays-heavy-price-for-ganja-possession-of-ammunition/" rel="bookmark" title="August 16, 2011">Grand Bay man pays heavy price for ganja, possession of ammunition</a></li></ul></ul></div></div></div><div class="col-md-6"><div class='widget first-ad administer-ad-container'><div id='administer-ad-408' class='administer-ad'><a id='administer-adlink-408' class='' href='https://dominicanewsonline.com/news/?administer_redirect_408=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fdominica-calypso-2022-playlist%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Dominica Calypso 2022 article bottom right'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/calypso-305-1.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/calypso-305-1.jpg' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></div></div><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-full-width-responsive="true" data-ad-format="auto" data-ad-client="ca-pub-6732730031512336" data-ad-slot="8545362756"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></footer></article><div id="comments" class="comment-area"><div id="disclaimer"><p> <b>Disclaimer:</b> The comments on this page do not necessarily reflect the views of
DominicaNewsOnline.com/Duravision Inc. All comments are approved by DominicaNewsOnline.com
before they are posted. We never censor based on political or ideological points of view,
but we do try to maintain a sensible balance between free speech and responsible moderating. <br /><br /> We <b>will</b> delete comments that:</p><ul><li>violate or infringe the rights of any person, are defamatory or harassing or include personal attacks</li><li>a reasonable person would consider abusive or profane</li><li>contain material which violates or encourages others to violate any applicable law</li><li>promote hatred of any kind</li><li>refer to people arrested or charged with a crime as though they had been found guilty</li><li>contain links to "chain letters", pornographic or obscene movies or graphic images</li><li>are excessively long and off-topic</li></ul><p> See our full <a href="https://dominicanewsonline.com/news/policies/#comment-policy">comment/user policy/agreement.</a></p></div><h3 class="comments-title">1 Comment</h3><ol class="comment-list"><li id="comment-2990907" class="comment even thread-even depth-1 clearfix"><header class="comment-header"><div class="commenter-avatar-wrapper"> <a target="_blank" href="https://en.gravatar.com" title="Get Your Gravatar"><img alt='' src='https://secure.gravatar.com/avatar/1249d118ef3ae7a6e7affd839db80e4f?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1249d118ef3ae7a6e7affd839db80e4f?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy' /></a></div><div class="comment-info"><div class="commenter"> derp</div><div class="meta-info"> <span class="date">February 11, 2022</span></div></div></header><div class="comment-text"><div style="background:none !important"><p>This is only those they catching eh people much less for the people brining it in and they not catching. Now you have the law abiding citizen and you have to go and beg the government to protect yourself if you want to get a firearm, when it has them fella outside with those weapons getting it black is white. You already know police in Dominica slow and cannot protect nobody&#8230;</p></div></div><footer class="comment-footer"> <span class="comment-rating-wrapper"> Well-loved. Like or Dislike: <img style="padding: 0px; border: none; cursor: pointer;" id="up-2990907" src="https://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_up.png" alt="Thumb up" onclick="javascript:ckratingKarma('2990907', 'add', 'https://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_');" title="Thumb Up" /> <span id="karma-2990907-up" style="font-size:12px; color:#009933;">13</span>&nbsp;<img style="padding: 0px; border: none; cursor: pointer;" id="down-2990907" src="https://dominicanewsonline.com/news/wp-content/plugins/comment-rating/images/1_14_down.png" alt="Thumb down" onclick="javascript:ckratingKarma('2990907', 'subtract', 'https://dominicanewsonline.com/news/wp-content/plugins/comment-rating/', '1_14_')" title="Thumb Down" /> <span id="karma-2990907-down" style="font-size:12px; color:#990033;">6</span> </span><div class="comment-reply-link-wrapper"><a rel='nofollow' class='comment-reply-link' href='#comment-2990907' data-commentid="2990907" data-postid="280914" data-belowelement="comment-2990907" data-respondelement="respond" data-replyto="Reply to derp" aria-label='Reply to derp'><i class="fa fa-reply" aria-hidden="true"></i> <span title="Reply to this comment">Reply</span></a></div></footer></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Post a Comment <small> <a rel="nofollow" id="cancel-comment-reply-link" href="/news/homepage/news/grand-bay-man-charged-with-firearm-belvue-chopin-man-pleads-guilty-to-importation-of-ammunition/#respond" style="display:none;">| Cancel Reply</a></small></h3><form action="https://dominicanewsonline.com/news/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment</label><span class="smilies"> <script type="text/javascript">function grin(tag) {
    	if (typeof tinyMCE != 'undefined') {
    		grin_tinymcecomments(tag);
    	} else {
    		grin_plain(tag);
    	}
    }
    function grin_tinymcecomments(tag) {
    	tinyMCE.execCommand('mceInsertContent', false, ' ' + tag + ' ');
    }
    
    function grin_plain(tag) {
    	var myField;
    	var myCommentTextarea = "comment";
    	tag = ' ' + tag + ' ';
        if (document.getElementById(myCommentTextarea) && document.getElementById(myCommentTextarea).type == 'textarea') {
    		myField = document.getElementById(myCommentTextarea);
    	} else {
    		return false;
    	}
    	if (document.selection) {
    		myField.focus();
    		sel = document.selection.createRange();
    		sel.text = tag;
    		myField.focus();
    	}
    	else if (myField.selectionStart || myField.selectionStart == '0') {
    		var startPos = myField.selectionStart;
    		var endPos = myField.selectionEnd;
    		var cursorPos = endPos;
    		myField.value = myField.value.substring(0, startPos)
    					  + tag
    					  + myField.value.substring(endPos, myField.value.length);
    		cursorPos += tag.length;
    		myField.focus();
    		myField.selectionStart = cursorPos;
    		myField.selectionEnd = cursorPos;
    	}
    	else {
    		myField.value += tag;
    		myField.focus();
    	}
    }
    
    function moreSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'inline';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:lessSmilies()">&laquo;&nbsp;less</a></span>';
    }
    
    function lessSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'none';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:moreSmilies()">more&nbsp;&raquo;</a>';
    }</script> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_smile.gif' alt=':)' onclick='grin(":)")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_biggrin.gif' alt=':-D' onclick='grin(":-D")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_wink.gif' alt=':wink:' onclick='grin(":wink:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_sad.gif' alt=':(' onclick='grin(":(")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_eek.gif' alt='8-O' onclick='grin("8-O")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif' alt=':lol:' onclick='grin(":lol:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_neutral.gif' alt=':-|' onclick='grin(":-|")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cry.gif' alt=':cry:' onclick='grin(":cry:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cool.gif' alt='8)' onclick='grin("8)")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_confused.gif' alt=':-?' onclick='grin(":-?")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_razz.gif' alt=':-P' onclick='grin(":-P")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mad.gif' alt=':-x' onclick='grin(":-x")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_question.gif' alt=':?:' onclick='grin(":?:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_redface.gif' alt=':oops:' onclick='grin(":oops:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_twisted.gif' alt=':twisted:' onclick='grin(":twisted:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mrgreen.gif' alt=':mrgreen:' onclick='grin(":mrgreen:")' class='wp-smiley-select' /> <span id="wp-smiley-more" style="display:none"><img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif' alt=':roll:' onclick='grin(":roll:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_idea.gif' alt=':idea:' onclick='grin(":idea:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_evil.gif' alt=':evil:' onclick='grin(":evil:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_arrow.gif' alt=':arrow:' onclick='grin(":arrow:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_surprised.gif' alt=':-o' onclick='grin(":-o")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_exclaim.gif' alt=':!:' onclick='grin(":!:")' class='wp-smiley-select' /> </span> <span id="wp-smiley-toggle"><a href="javascript:moreSmilies()">more&nbsp;&raquo;</a></span></span><textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true" onkeydown="gcllCounter(this)" onkeyup="gcllCounter(this)"></textarea></p><span class="countdownbox"> <input class="form-control" readonly="readonly" type="text" id="commentlen" size="4" maxlength="4" value="1000" style="width:auto;text-indent:0;" /> &nbsp;characters available </span><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" maxlength="245" required /></p><p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required /></p><p class="comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='280914' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="aaa9f993ab" /></p> <script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='54b72601f99c96d48143ff65350c92ad';
hf1V='0a40dd4706b9cf3982e14a48a84a0d79';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script> <noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript> <noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="114" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></div></main></div></div><div id="secondary-wrapper" class="col-md-4 col-sm-5"><aside id="secondary" class="sidebar widget-area"><section id="administerwidget-48" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-20' class='administer-ad'><a id='administer-adlink-20' class='' href='https://dominicanewsonline.com/news/?administer_redirect_20=https%3A%2F%2Fstore.archip.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Right (Patty Shack)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Gif-for-Novermber-2021-1.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Gif-for-Novermber-2021-1.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-47" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-63' class='administer-ad'><a id='administer-adlink-63' class='' href='https://dominicanewsonline.com/news/?administer_redirect_63=http%3A%2F%2Fndfd.dm%2F2020%2F08%2F09%2Fbusiness-entrepreneurial-development-manager-vacancy%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NDFD- article side (formerly home side as well)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/NDFD-February-2022.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/01/NDFD-February-2022.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-40" class="widget widget_administerwidget"><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:100%;height:250px" data-full-width-responsive="true" data-ad-client="ca-pub-6732730031512336" data-ad-slot="6349001291"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id="administerwidget-41" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-406' class='administer-ad'><a id='administer-adlink-406' class='' href='https://dominicanewsonline.com/news/?administer_redirect_406=https%3A%2F%2Fwww.kempinski.com%2Fen%2Fdominica%2Fcabrits-resort-kempinski-dominica%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Kempinski promo (including valentines day promotion)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/kempinski-gif-2.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2022/02/kempinski-gif-2.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-42" class="widget widget_administerwidget"><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:100%;height:250px" data-full-width-responsive="true" data-ad-client="ca-pub-6732730031512336" data-ad-slot="1537364600"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id="administerwidget-43" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-80' class='administer-ad'><a id='administer-adlink-80' class='' href='https://dominicanewsonline.com/news/?administer_redirect_80=http%3A%2F%2Fwww.crimestoppersdominica.org' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Crime Stoppers'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2018/06/CSD-Dont-look-away-306.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2018/06/CSD-Dont-look-away-306.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-49" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-210' class='administer-ad'><a id='administer-adlink-210' class='' href='https://dominicanewsonline.com/news/?administer_redirect_210=http%3A%2F%2Fwww.weather.gov.dm%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Weather Widget Promotion'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2019/06/Weather-Report-min.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2019/06/Weather-Report-min.jpg' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="polls-widget-3" class="widget widget_polls-widget"><h2 class="widget-title">Polls</h2><p>Sorry, there are no polls available at the moment.</p></section></aside></div></div></div><footer id="colophon" class="site-footer container-fluid"><div class="site-info"><div class="row"><div class="col-sm-6"><ul class="footer-links"><li><a href="https://dominicanewsonline.com/news/policies/#privacy">Privacy Policy</a></li><li><a href="https://dominicanewsonline.com/news/policies/#disclaimers">Disclaimers</a></li><li><a href="https://dominicanewsonline.com/news/policies/#comment-policy">Comment Policy</a></li><li><a href="https://dominicanewsonline.com/news/policies/#faq">Frequently Asked Questions</a></li><li><a href="https://dominicanewsonline.com/news/contact/">Contact Us</a></li></ul></div><div class="col-sm-6"><p class="social-links"> <a class="social-link social-rss" target="_blank" title="Subscribe to our RSS Feed" href="https://feeds.feedburner.com/DominicaNewsOnline/"><i class="fas fa-rss-square fa-4x"></i></a> <a class="social-link social-facebook" target="_blank" title="Follow us on Facebook" href="https://www.facebook.com/DominicaNewsOnline"><i class="fab fa-facebook fa-4x"></i></a> <a class="social-link social-twitter" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"><i class="fab fa-twitter-square fa-4x"></i></a> <a class="social-link social-instagram" target="_blank" title="Follow us on Instagram" href="https://www.instagram.com/dominicanewsonline"><i class="fab fa-instagram fa-4x"></i></a></p></div></div><p> <a href="https://dominicanewsonline.com/news/policies/#copyright">Copyright &#169; 2007-2022</a> Dominica News Online, Duravision Inc &#8226; Roseau, Dominica &#8226; All rights reserved.</p></div> <a id="back-to-top" class="back-to-top" title="Go to the top of the page" href="javascript:void(0)"><i class="fas fa-arrow-alt-circle-up fa-4x"></i></i></a></footer></div></div></div></div> <script type="text/javascript">function gcllCounter(textarea) {
if (textarea.value.length > 1000)
textarea.value = textarea.value.substring(0, 1000);
else
document.getElementById('commentlen').value = 1000 - textarea.value.length;
}</script>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='54b72601f99c96d48143ff65350c92ad';
hf4V='0a40dd4706b9cf3982e14a48a84a0d79';
cm4S="form[action='https://dominicanewsonline.com/news/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <div id="fb-root"></div> <script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.1&appId=246787465390190&autoLogAppEvents=1';
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script> <script type="text/javascript" language="javascript">!function(d,s,id){
			var js,fjs=d.getElementsByTagName(s)[0];
			if(!d.getElementById(id)){
				js=d.createElement(s);
				js.id=id;js.src="//platform.twitter.com/widgets.js";
				fjs.parentNode.insertBefore(js,fjs);
			}
		}(document,"script","twitter-wjs");</script>
<script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script>if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"https:\/\/dominicanewsonline.com\/news\/wp.serviceworker",
							{"scope":"\/news\/"}						).then( reg => {
													} );
					}
							} );
		}</script> <script type='text/javascript' id='cookie-consent-js-extra'>var ctcc_vars = {"expiry":"30","method":"1","version":"1"};</script> <script type='text/javascript' id='wp-polls-js-extra'>var pollsL10n = {"ajax_url":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript' id='social_warfare_script-js-extra'>var socialWarfare = {"addons":[],"post_id":"280914","variables":{"emphasizeIcons":false,"powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};</script> <script type='text/javascript' data-cfasync='false' src='https://dominicanewsonline.com/news/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script type='text/javascript' id='navigation-cache-js-extra'>var page_nav_js_config = {"ajaxurl":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});</script> <script type='text/javascript' id='custom-functions-js-extra'>var dno_load_more_posts_config = {"ajaxurl":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","security":"3f14d8790d","max_page":"0"};</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js' id='wpss-jscripts-ftr-js'></script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript">var swp_nonce = "e3158c022a";var swpFloatBeforeContent = false; var swp_ajax_url = "https://dominicanewsonline.com/news/wp-admin/admin-ajax.php"; var swp_post_id = "280914";var swpClickTracking = false;</script><script src='https://stats.wp.com/e-202206.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6',blog:'41008113',post:'280914',tz:'-4',srv:'dominicanewsonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '41008113', '280914' ]);</script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});</script> <div id="catapult-cookie-bar" class=" use_x_close"><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies to provide a better user experience. By using our site, you acknowledge that you have read and understand our Cookie Policy, Privacy Policy, and our Terms of Service. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://dominicanewsonline.com/news/policies/#cookie-policy">Find out more.</a></span><span class="ctcc-right-side"></span><div class="x_close"><span></span><span></span></div></div></div> <script defer src="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/js/autoptimize_274476332ae5ab8c96eb7b05bb1f6894.js"></script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6dc812242f1f59d3',m:'KzjWHBwLhOhLoc_gkDL.iXwp0EuGho2T_QBRE0vgtLE-1644692542-0-Abg5bz1UWoeHzzeiNt+RW0CQbzOXHVfehYyXrScSt9/4gR2CJ1FTUMPtWtRCsM1FF4SlYbaqKlfENbUjPVGHN+WOHwqH61yI50hnm1CVcjJE68p0GaxCDO3OBY5bUA5f6bOjUlqHVnN82IeZ/hFcrf4KTDhDuLSEP1sh9dj4La1tX2O7L//tx0/1eVsRMyIEGu3Ulw/fzBSU5qDzT0Of3flx3iEXXXyFJe0GMvtGcZS7qCRq9V8jnURTPfn/wTRq/h6hcmoF58jAOVN6YFq6qEE=',s:[0xdf3ca89a8a,0x16093924d8],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6dc812242f1f59d3","token":"683ff6fa5f72425db3f1d3af6385627c","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body></html>


