<!DOCTYPE html><html lang="en-US"><head><meta http-equiv="x-ua-compatible" content="ie=edge"><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><meta name="google-site-verification" content="bBuHZdxdwW3W8iMT758WT6N3fo38yHZ-87h4XzOMyXw" /> <script data-ad-client="ca-pub-6732730031512336" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><link media="all" href="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/css/autoptimize_74f10e2a061afb1ef20c9e3830633688.css" rel="stylesheet" /><link media="screen" href="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/css/autoptimize_919be5d5dc481ff3d503e14e080e867c.css" rel="stylesheet" /><title>&#039;He defended and promoted the best interest of the Caribbean&#039; - DFP on the passing of former SVG PM, Sir James Mitchell - Dominica News Online</title><link rel="canonical" href="https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="&#039;He defended and promoted the best interest of the Caribbean&#039; - DFP on the passing of former SVG PM, Sir James Mitchell - Dominica News Online" /><meta property="og:description" content="The Dominica Freedom Party (DFP) has expressed sadness at the passing of Sir James Mitchell, former Prime Minister of St. Vincent and the Grenadines, who died at age 90 earlier today. &#8220;He was a dedicated public servant to the people..." /><meta property="og:url" content="https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/" /><meta property="og:site_name" content="Dominica News Online" /><meta property="article:published_time" content="2021-11-23T23:44:39+00:00" /><meta property="article:modified_time" content="2021-11-24T00:13:11+00:00" /><meta property="og:image" content="https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell.jpeg" /><meta property="og:image:width" content="360" /><meta property="og:image:height" content="240" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Admin" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dominicanewsonline.com/news/#website","url":"https://dominicanewsonline.com/news/","name":"Dominica News Online","description":"The most popular news site in the Commonwealth of Dominica","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dominicanewsonline.com/news/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#primaryimage","inLanguage":"en-US","url":"https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell.jpeg","contentUrl":"https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell.jpeg","width":360,"height":240,"caption":"Sir-James Mitchell"},{"@type":"WebPage","@id":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#webpage","url":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/","name":"'He defended and promoted the best interest of the Caribbean' - DFP on the passing of former SVG PM, Sir James Mitchell - Dominica News Online","isPartOf":{"@id":"https://dominicanewsonline.com/news/#website"},"primaryImageOfPage":{"@id":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#primaryimage"},"datePublished":"2021-11-23T23:44:39+00:00","dateModified":"2021-11-24T00:13:11+00:00","author":{"@id":"https://dominicanewsonline.com/news/#/schema/person/1cf13c57fb23f5f3f17888628ce87bed"},"breadcrumb":{"@id":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/"]}]},{"@type":"BreadcrumbList","@id":"https://dominicanewsonline.com/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dominicanewsonline.com/news/"},{"@type":"ListItem","position":2,"name":"&#8216;He defended and promoted the best interest of the Caribbean&#8217; &#8211; DFP on the passing of former SVG PM, Sir James Mitchell"}]},{"@type":"Person","@id":"https://dominicanewsonline.com/news/#/schema/person/1cf13c57fb23f5f3f17888628ce87bed","name":"Admin","image":{"@type":"ImageObject","@id":"https://dominicanewsonline.com/news/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68732e6ad6cd39603a4ac10588629490?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/68732e6ad6cd39603a4ac10588629490?s=96&d=mm&r=g","caption":"Admin"},"url":"https://dominicanewsonline.com/news/author/tdurand/"}]}</script> <link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="text/calendar" title="Dominica News Online &raquo; iCal Feed" href="https://dominicanewsonline.com/news/events/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dominicanewsonline.com\/news\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='awpcp-font-awesome-css' href='https://use.fontawesome.com/releases/v5.2.0/css/all.css' type='text/css' media='all' /> <!--[if lte IE 6]><link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' type='text/css' media='all' /> <![endif]--> <!--[if lte IE 7]><link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://dominicanewsonline.com/news/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' type='text/css' media='all' /> <![endif]--> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/dominicanewsonline.com\/news\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/dominicanewsonline.com\/news\/wp-json\/wordpress-popular-posts","ID":277651,"token":"eaacef58ef","lang":0,"debug":0}</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-content/cache/autoptimize/js/autoptimize_single_9ffdba2cff497d701684657e329871f5.js' id='swfobject-js'></script> <link rel="https://api.w.org/" href="https://dominicanewsonline.com/news/wp-json/" /><link rel="alternate" type="application/json" href="https://dominicanewsonline.com/news/wp-json/wp/v2/posts/277651" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dominicanewsonline.com/news/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dominicanewsonline.com/news/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://dominicanewsonline.com/news/?p=277651' /><link rel="alternate" type="application/json+oembed" href="https://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F" /><link rel="alternate" type="text/xml+oembed" href="https://dominicanewsonline.com/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F&#038;format=xml" /> <noscript><style>.ad-minister-ad img.lazyload { display: none; }</style></noscript> <script type="text/javascript" language="javascript">(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-28491038-1', 'auto');
			ga('set', 'contentGroup1', 'Articles');
			ga('send', 'pageview');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=G-MWJR60HYW5"></script> <script>window.dataLayer = window.dataLayer || [];
			function gtag(){dataLayer.push(arguments);}
			gtag('js', new Date());

			gtag('config', 'G-MWJR60HYW5');</script> <script type="text/javascript">function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}</script> <link rel="manifest" href="https://dominicanewsonline.com/news/wp-json/wp/v2/web-app-manifest"><meta name="theme-color" content="#ffffff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Dominica News Online"><meta name="application-name" content="Dominica News Online"><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dominicanewsonline.com/news"><link rel="https://theeventscalendar.com/" href="https://dominicanewsonline.com/news/wp-json/tribe/events/v1/" /><link rel="pingback" href="https://dominicanewsonline.com/news/xmlrpc.php"> <!--[if IE 9]><link href="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/css/bootstrap-ie9.min.css" rel="stylesheet"> <![endif]--> <!--[if lte IE 8]><link href="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/css/bootstrap-ie8.min.css" rel="stylesheet"> <script src="https://cdn.jsdelivr.net/g/html5shiv@3.7.3"></script> <![endif]--> <!--[if gte IE 9]> <script src="https://code.jquery.com/jquery-3.3.1.slim.min.js"></script> <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.6/umd/popper.min.js"></script> <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.min.js"></script> <![endif]--> <!--[if IE 9]> <script src="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/js/bootstrap-ie9.min.js"></script> <![endif]--> <!--[if lte IE 8]> <script src="https://code.jquery.com/jquery-1.12.4.min.js"></script> <script src="https://cdn.jsdelivr.net/gh/coliff/bootstrap-ie8/js/bootstrap-ie8.min.js"></script> <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.js"></script> <![endif]--> <script async src="https://powerad.ai/92906088025000/script.js"></script> <script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body data-rsssl=1 class="post-template-default single single-post postid-277651 single-format-standard tribe-no-js no-sidebar"><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><div class="container page-container"><div class="row"><div class="main-col col-12 col-sm-12 no-margin-banner"><header id="masthead" class="site-header"><div class="row no-gutters clearfix"><div class="col-md-4"><div class="logo-container"><div class="logo"> <a href="https://dominicanewsonline.com/news"> <img alt="Dominica News Online | Independent. Immediate. Trusted." src="https://dominicanewsonline.com/news/wp-content/themes/dnobootstrap/images/DNO-Logo.png" /> </a></div><div class="social-buttons" id="social-buttons"><div class="social-button"><div class="fb-like" data-href="https://www.facebook.com/DominicaNewsOnline" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false"></div></div><div class="social-button"> <a class="twitter-follow-button" href="https://twitter.com/DNONews" data-show-count="false" data-show-screen-name="false">Follow @DNONews</a></div></div></div></div><div class="col-md-8"><div class="logo-banner-wrapper clearfix"><div data-timeout='15000' data-fx='scroll' class='logoBanner tcycle administer-ad-container'><div id='administer-ad-25' class='administer-ad'><a id='administer-adlink-25' class='' href='https://dominicanewsonline.com/news/?administer_redirect_25=https%3A%2F%2Fsecure.moneygram.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Logo (Money Gram)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2020/12/GTM0002778_AMERICAS-Holiday-digital-campaign-2020_642x140px_Eng.jpg' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2020/12/GTM0002778_AMERICAS-Holiday-digital-campaign-2020_642x140px_Eng.jpg' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div><div id='administer-ad-136' class='administer-ad'><a id='administer-adlink-136' class='' href='https://dominicanewsonline.com/news/?administer_redirect_136=http%3A%2F%2Fwww.nccudominica.com%2FCU-Online-%2FCU-Online.html' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NCCU Article Menu Banner - Online services'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/05/NCCU-LTD-CU-Online-Services.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/05/NCCU-LTD-CU-Online-Services.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div></div></div></div><nav class="navbar navbar-expand-lg navbar-dark clearfix" role="navigation"> <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-menu-main" aria-controls="navbar-menu-main" aria-expanded="false" aria-label="Toggle navigation"> <span class="navbar-toggler-icon"></span> </button><div id="navbar-menu-main" class="mx-auto collapse navbar-collapse"><ul id="menu-main-menu" class="navbar-nav mx-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-60267 nav-item"><a title="Home" href="https://dominicanewsonline.com/news/" class="nav-link"><i class="fa fa-home"></i> Home</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-216822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-216822 nav-item"><a title="Categories" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link" id="menu-item-dropdown-216822">Categories</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-216822" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-252735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252735 nav-item"><a title="Historical" href="https://dominicanewsonline.com/news/category/homepage/news/historical/" class="dropdown-item">Historical</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109591" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent active menu-item-109591 nav-item"><a title="News" href="https://dominicanewsonline.com/news/category/homepage/news/" class="dropdown-item">News</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109606 nav-item"><a title="Announcements" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109606">Announcements</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109606" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-141462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141462 nav-item"><a title="Death Announcements" href="https://dominicanewsonline.com/news/category/announcements/death-announcements/" class="dropdown-item">Death Announcements</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-141463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141463 nav-item"><a title="General Announcements" href="https://dominicanewsonline.com/news/category/announcements/general-announcements/" class="dropdown-item">General Announcements</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109592 nav-item"><a title="Columns" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109592">Columns</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109592" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109593 nav-item"><a title="Alive Word" href="https://dominicanewsonline.com/news/category/homepage/columns/alive-word/" class="dropdown-item">Alive Word</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109594 nav-item"><a title="CariMAN" href="https://dominicanewsonline.com/news/category/homepage/columns/cariman/" class="dropdown-item">CariMAN</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109595 nav-item"><a title="Dear Bella" href="https://dominicanewsonline.com/news/category/homepage/columns/dear-bella/" class="dropdown-item">Dear Bella</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109596 nav-item"><a title="Ghost Stories" href="https://dominicanewsonline.com/news/category/homepage/columns/ghost-stories/" class="dropdown-item">Ghost Stories</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109597 nav-item"><a title="Health Talk" href="https://dominicanewsonline.com/news/category/homepage/columns/health-talk/" class="dropdown-item">Health Talk</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109598 nav-item"><a title="Just Dennis" href="https://dominicanewsonline.com/news/category/homepage/columns/just-dennis/" class="dropdown-item">Just Dennis</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109599 nav-item"><a title="Natural Healing" href="https://dominicanewsonline.com/news/category/homepage/columns/natural-healing/" class="dropdown-item">Natural Healing</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109600 nav-item"><a title="Stay Well &amp; Sparkle!" href="https://dominicanewsonline.com/news/category/homepage/columns/stay-well-sparkle/" class="dropdown-item">Stay Well &amp; Sparkle!</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown dropdown-submenu menu-item-109601 nav-item"><a title="Features" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle dropdown-item" id="menu-item-dropdown-109601">Features</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-109601" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109602 nav-item"><a title="Business In Focus" href="https://dominicanewsonline.com/news/category/homepage/features/business-features/" class="dropdown-item">Business In Focus</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109603 nav-item"><a title="Check This Out" href="https://dominicanewsonline.com/news/category/homepage/features/check-this-out/" class="dropdown-item">Check This Out</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109604 nav-item"><a title="Commentary" href="https://dominicanewsonline.com/news/category/homepage/features/commentary/" class="dropdown-item">Commentary</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109605 nav-item"><a title="Letters to the Editor" href="https://dominicanewsonline.com/news/category/homepage/features/letters-to-the-editor/" class="dropdown-item">Letters to the Editor</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-251939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251939 nav-item"><a title="Featured Photo" href="https://dominicanewsonline.com/news/category/homepage/features/featured-photo/" class="dropdown-item">Featured Photo</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-109608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109608 nav-item"><a title="Poetry Corner" href="https://dominicanewsonline.com/news/category/homepage/features/poetry/" class="dropdown-item">Poetry Corner</a></li></ul></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-87503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87503 nav-item"><a title="Business Directory" href="https://dominicanewsonline.com/news/business-directory/" class="nav-link">Business Directory</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60279 nav-item"><a title="Classifieds" href="https://dominicanewsonline.com/news/classifieds/" class="nav-link">Classifieds</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-157540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157540 nav-item"><a title="Events" href="https://dominicanewsonline.com/news/events/" class="nav-link">Events</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60280 nav-item"><a title="Contact Us" href="https://dominicanewsonline.com/news/contact/" class="nav-link">Contact Us</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-64197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64197 nav-item"><a title="News Links" href="https://dominicanewsonline.com/news/news-links/" class="nav-link">News Links</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-265770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-265770 nav-item"><a title="Combatting COVID-19" href="https://dominicanewsonline.com/news/combatting-covid-19/" class="nav-link">Combatting COVID-19</a></li></ul></div></nav><div class="menu-banner-wrapper clearfix"><div class='menu-banner-left first-ad administer-ad-container'><div id='administer-ad-95' class='administer-ad'><a id='administer-adlink-95' class='' href='https://dominicanewsonline.com/news/?administer_redirect_95=http%3A%2F%2Fwww.kfcdominica.com' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'FFI KFC GENIUS + Catch of The day (2) - Home Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/KFC-DOM-DNO-10.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/KFC-DOM-DNO-10.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div><div class='menu-banner-right first-ad administer-ad-container'><div id='administer-ad-387' class='administer-ad'><a id='administer-adlink-387' class='' href='https://dominicanewsonline.com/news/?administer_redirect_387=https%3A%2F%2Fnbdominica.com%2Fcreole-christmas-season%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NBD Christmas promotion 2021 Oct 13 to Dec 31st'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/10/NBD-Christmas-2021.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/10/NBD-Christmas-2021.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div></div><div id="toolBar" class="toolbar row no-gutters clearfix"><div class="col-sm-4 col-md-3"><div class="toolBarButtons clearfix"><div class="social-links row no-gutters"><div class="col"> <a class="social-link social-rss" target="_blank" title="Subscribe to our RSS Feed" href="https://feeds.feedburner.com/DominicaNewsOnline/"><i class="fas fa-rss-square fa-2x"></i></a></div><div class="col"> <a class="social-link social-facebook" target="_blank" title="Follow us on Facebook" href="https://www.facebook.com/DominicaNewsOnline"><i class="fab fa-facebook fa-2x"></i></a></div><div class="col"> <a class="social-link social-twitter" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"><i class="fab fa-twitter-square fa-2x"></i></a></div><div class="col"> <a class="social-link social-instagram" target="_blank" title="Follow us on Instagram" href="https://www.instagram.com/dominicanewsonline"><i class="fab fa-instagram fa-2x"></i></a></div></div></div></div><div class="col-sm-8 col-md-6"><div id="ticker" class="ticker"><div class="marquee">DNO, your <strong>only</strong> source for news that is<strong> iit&nbsp;</strong>- <strong>I</strong>ndependent.<strong> I</strong>mmediate. <strong>T</strong>rusted.</div></div></div><div class="col-md-3"><form id="searchBar" class="row no-gutters" name="searchBar" method="get" action="https://dominicanewsonline.com/news"><div class="input-group"> <input id="searchField" class="form-control" type="search" name="s" placeholder="Search..." value=""> <input id="searchButton" type="button" title="Search" value=" "></div></form></div></div></header><div id="content" class="site-content"><div class="row"><div id="primary-wrapper" class="col-md-8 col-sm-7"><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-277651" class="clearfix post-277651 post type-post status-publish format-standard has-post-thumbnail hentry category-homepage-carousel category-news category-politics category-regional"><div data-timeout='15000' data-fx='scroll' class='contentBanner tcycle administer-ad-container'><div id='administer-ad-82' class='administer-ad'><a id='administer-adlink-82' class='' href='https://dominicanewsonline.com/news/?administer_redirect_82=https%3A%2F%2Fspringbel.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Springfield Trading - Article Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2019/10/springfield-trading-oct.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2019/10/springfield-trading-oct.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div><div id='administer-ad-263' class='administer-ad'><a id='administer-adlink-263' class='' href='https://dominicanewsonline.com/news/?administer_redirect_263=https%3A%2F%2Fwww.campbells-art.com%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Campbell's Business Machines (Banners, Posters, Signs) Article Headline'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/09/Campbells-Banner-Gif.gif' style='width: 642px; height: 140px; ' width='642' height='140'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/09/Campbells-Banner-Gif.gif' style='width: 642px; height: 140px; ' width='642' height='140' /></a></div></div><nav class='breadcrumb'><a href="https://dominicanewsonline.com/news/" alt='Home' title='Home'>Home</a><span class='divider'>&nbsp;&gt;&gt;&nbsp;</span><a href='https://dominicanewsonline.com/news/category/homepage/news/' title='News'>News</a></nav><header class="entry-header"><h1 class="entry-title">&#8216;He defended and promoted the best interest of the Caribbean&#8217; &#8211; DFP on the passing of former SVG PM, Sir James Mitchell</h1><div class="entry-meta"> <strong>DFP/DNO - </strong>Tuesday, November 23rd, 2021 at 7:44 PM</div></header><div class="entry-content"><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="none" data-float-mobile="none" data-transition="slide" data-post-id="277651"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=%27He+defended+and+promoted+the+best+interest+of+the+Caribbean%27+-+DFP+on+the+passing+of+former+SVG+PM%2C+Sir+James+Mitchell&url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F" data-link="https://twitter.com/intent/tweet?text=%27He+defended+and+promoted+the+best+interest+of+the+Caribbean%27+-+DFP+on+the+passing+of+former+SVG+PM%2C+Sir+James+Mitchell&url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fhomepage%2Fnews%2Fhe-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
 e.setAttribute('type','text/javascript');
 e.setAttribute('charset','UTF-8');
 e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
 document.body.appendChild(e);
 "><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div></div><figure id="attachment_277653" aria-describedby="caption-attachment-277653" style="width: 494px" class="wp-caption aligncenter"><img loading="lazy" class=" wp-image-277653" src="https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell.jpeg" alt="" width="494" height="329" srcset="https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell.jpeg 360w, https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Sir-James-Mitchell-300x200.jpeg 300w" sizes="(max-width: 494px) 100vw, 494px" /><figcaption id="caption-attachment-277653" class="wp-caption-text">Sir-James Mitchell</figcaption></figure><p>The Dominica Freedom Party (DFP) has expressed sadness at the passing of Sir James Mitchell, former Prime Minister of St. Vincent and the Grenadines, who died at age 90 earlier today.</p><p>&#8220;He was a dedicated public servant to the people of his country and Caribbean region as a whole, who entered the political arena in the early 1970’s and remained the parliamentary representative for the Northern Grenadines constituency until his retirement from electoral politics in 2001,&#8221; a release from the DFP states.</p><p>Sir Mitchell was Premier from 1972 to 1974. He was a  founding member of the New Democratic Party in 1975 which he served as President and Political Leader until 2001. He became the second Prime Minister of St. Vincent and the Grenadines and served from 1984 to 2000 when he passed on the torch to Mr. Arnhim Eustace.</p><p>According to the DFP release, Sir James was a true and well respected Caribbean leader who cared for the well – being of the people of his country and the region generally.</p><p>&#8220;He defended and promoted the best interest of the Caribbean, particularly Bananas, Trade and Investment alongside leaders like the late Dame Eugenia Charles at every opportunity they were given,&#8221; the release adds.</p><p>The DFP also remembers the late former prime minister who was the featured speaker at the Dominica Freedom Party’s delegates convention in 2008, &#8220;as one of those Prime Ministers who were strong and steadfast in the pursuit of Caribbean integration/ unity.&#8221;</p><p>&#8220;A true states man and nation builder who was committed to democracy and responsible governance, frank and humble. We extend our deepest condolences to his family, colleagues in the New Democratic Party, the people of the Northern Grenadines which he represented in Parliament for a number of years and the people of St. Vincent and the Grenadines generally,&#8221; the release goes on to state. &#8220;May his soul rest in eternal peace.&#8221;</p><div class="swp-content-locator"></div></div><footer class="entry-footer"><div class="post-copyright"><p> Copyright 2012 Dominica News Online, DURAVISION INC. All Rights Reserved. This material may not be published, broadcast, rewritten or distributed.</p></div><div class="widget-bar row"><div class="col-md-6"><div id="relatedPosts" class="widget"><h3 class="widget-title">Related Articles</h3><div class="newsItems"><ul><ul><li><a href="https://dominicanewsonline.com/news/homepage/news/politics/dfp-sends-congratulations-following-general-elections-in-st-vincent-and-the-grenadines/" rel="bookmark" title="December 16, 2010">DFP sends congratulations following general elections in St. Vincent and the Grenadines</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/politics/pm-skerrit-congratulates-new-barbados-prime-minister/" rel="bookmark" title="May 28, 2018">PM Skerrit congratulates new Barbados Prime Minister</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/regional/oecs-calls-for-public-calm-in-st-vincent-opposition-vows-massive-civil-protest/" rel="bookmark" title="December 18, 2015">OECS calls for public calm in St. Vincent; opposition vows massive civil protest</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/st-vincent-grenadines-prime-minister-comments-on-sex-tape/" rel="bookmark" title="November 11, 2015">St. Vincent &#038; Grenadines prime minister comments on sex tape</a></li><li><a href="https://dominicanewsonline.com/news/homepage/news/politics/national-holiday-declared-in-grenada/" rel="bookmark" title="February 20, 2013">National holiday declared in Grenada</a></li></ul></ul></div></div></div><div class="col-md-6"><div class='widget first-ad administer-ad-container'><div id='administer-ad-393' class='administer-ad'><a id='administer-adlink-393' class='' href='https://dominicanewsonline.com/news/?administer_redirect_393=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fundp-guydom-page%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'UNDP Page GUYDOM week of activities 306 X 250 article side 4 and bottom right'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/UNDP-306.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/UNDP-306.jpg' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></div></div><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-full-width-responsive="true" data-ad-format="auto" data-ad-client="ca-pub-6732730031512336" data-ad-slot="8545362756"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></footer></article><div id="comments" class="comment-area"><div id="disclaimer"><p> <b>Disclaimer:</b> The comments on this page do not necessarily reflect the views of
DominicaNewsOnline.com/Duravision Inc. All comments are approved by DominicaNewsOnline.com
before they are posted. We never censor based on political or ideological points of view,
but we do try to maintain a sensible balance between free speech and responsible moderating. <br /><br /> We <b>will</b> delete comments that:</p><ul><li>violate or infringe the rights of any person, are defamatory or harassing or include personal attacks</li><li>a reasonable person would consider abusive or profane</li><li>contain material which violates or encourages others to violate any applicable law</li><li>promote hatred of any kind</li><li>refer to people arrested or charged with a crime as though they had been found guilty</li><li>contain links to "chain letters", pornographic or obscene movies or graphic images</li><li>are excessively long and off-topic</li></ul><p> See our full <a href="https://dominicanewsonline.com/news/policies/#comment-policy">comment/user policy/agreement.</a></p></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Post a Comment <small> <a rel="nofollow" id="cancel-comment-reply-link" href="/news/homepage/news/he-defended-and-promoted-the-best-interest-of-the-caribbean-dfp-on-the-passing-of-former-svg-pm-sir-james-mitchell/#respond" style="display:none;">| Cancel Reply</a></small></h3><form action="https://dominicanewsonline.com/news/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><span class="smilies"> <script type="text/javascript">function grin(tag) {
    	if (typeof tinyMCE != 'undefined') {
    		grin_tinymcecomments(tag);
    	} else {
    		grin_plain(tag);
    	}
    }
    function grin_tinymcecomments(tag) {
    	tinyMCE.execCommand('mceInsertContent', false, ' ' + tag + ' ');
    }
    
    function grin_plain(tag) {
    	var myField;
    	var myCommentTextarea = "comment";
    	tag = ' ' + tag + ' ';
        if (document.getElementById(myCommentTextarea) && document.getElementById(myCommentTextarea).type == 'textarea') {
    		myField = document.getElementById(myCommentTextarea);
    	} else {
    		return false;
    	}
    	if (document.selection) {
    		myField.focus();
    		sel = document.selection.createRange();
    		sel.text = tag;
    		myField.focus();
    	}
    	else if (myField.selectionStart || myField.selectionStart == '0') {
    		var startPos = myField.selectionStart;
    		var endPos = myField.selectionEnd;
    		var cursorPos = endPos;
    		myField.value = myField.value.substring(0, startPos)
    					  + tag
    					  + myField.value.substring(endPos, myField.value.length);
    		cursorPos += tag.length;
    		myField.focus();
    		myField.selectionStart = cursorPos;
    		myField.selectionEnd = cursorPos;
    	}
    	else {
    		myField.value += tag;
    		myField.focus();
    	}
    }
    
    function moreSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'inline';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:lessSmilies()">&laquo;&nbsp;less</a></span>';
    }
    
    function lessSmilies() {
    	document.getElementById('wp-smiley-more').style.display = 'none';
    	document.getElementById('wp-smiley-toggle').innerHTML = '<a href="javascript:moreSmilies()">more&nbsp;&raquo;</a>';
    }</script> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_smile.gif' alt=':)' onclick='grin(":)")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_biggrin.gif' alt=':-D' onclick='grin(":-D")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_wink.gif' alt=':wink:' onclick='grin(":wink:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_sad.gif' alt=':(' onclick='grin(":(")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_eek.gif' alt='8-O' onclick='grin("8-O")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_lol.gif' alt=':lol:' onclick='grin(":lol:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_neutral.gif' alt=':-|' onclick='grin(":-|")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cry.gif' alt=':cry:' onclick='grin(":cry:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_cool.gif' alt='8)' onclick='grin("8)")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_confused.gif' alt=':-?' onclick='grin(":-?")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_razz.gif' alt=':-P' onclick='grin(":-P")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mad.gif' alt=':-x' onclick='grin(":-x")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_question.gif' alt=':?:' onclick='grin(":?:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_redface.gif' alt=':oops:' onclick='grin(":oops:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_twisted.gif' alt=':twisted:' onclick='grin(":twisted:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_mrgreen.gif' alt=':mrgreen:' onclick='grin(":mrgreen:")' class='wp-smiley-select' /> <span id="wp-smiley-more" style="display:none"><img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_rolleyes.gif' alt=':roll:' onclick='grin(":roll:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_idea.gif' alt=':idea:' onclick='grin(":idea:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_evil.gif' alt=':evil:' onclick='grin(":evil:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_arrow.gif' alt=':arrow:' onclick='grin(":arrow:")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_surprised.gif' alt=':-o' onclick='grin(":-o")' class='wp-smiley-select' /> <img src='https://dominicanewsonline.com/news/wp-includes/images/smilies/icon_exclaim.gif' alt=':!:' onclick='grin(":!:")' class='wp-smiley-select' /> </span> <span id="wp-smiley-toggle"><a href="javascript:moreSmilies()">more&nbsp;&raquo;</a></span></span><textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true" onkeydown="gcllCounter(this)" onkeyup="gcllCounter(this)"></textarea></p><span class="countdownbox"> <input class="form-control" readonly="readonly" type="text" id="commentlen" size="4" maxlength="4" value="1000" style="width:auto;text-indent:0;" /> &nbsp;characters available </span><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='277651' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="259355c28d" /></p> <script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='f7ba47c3641e34877f440ac644fef64c';
hf1V='e61b830ca53fa1765551829f0e05815a';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script> <noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript> <noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="53" /><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></div></main></div></div><div id="secondary-wrapper" class="col-md-4 col-sm-5"><aside id="secondary" class="sidebar widget-area"><section id="administerwidget-48" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-20' class='administer-ad'><a id='administer-adlink-20' class='' href='https://dominicanewsonline.com/news/?administer_redirect_20=https%3A%2F%2Fwww.facebook.com%2Farchipelagoltd%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Archipelago Trading Article Right (Patty Shack)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Gif-for-Novermber-2021.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/Gif-for-Novermber-2021.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-47" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-63' class='administer-ad'><a id='administer-adlink-63' class='' href='https://dominicanewsonline.com/news/?administer_redirect_63=http%3A%2F%2Fndfd.dm%2F2020%2F08%2F09%2Fbusiness-entrepreneurial-development-manager-vacancy%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'NDFD- article side (formerly home side as well)'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/10/NDFD-October-2021.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/10/NDFD-October-2021.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-40" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-393' class='administer-ad'><a id='administer-adlink-393' class='' href='https://dominicanewsonline.com/news/?administer_redirect_393=https%3A%2F%2Fdominicanewsonline.com%2Fnews%2Fundp-guydom-page%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'UNDP Page GUYDOM week of activities 306 X 250 article side 4 and bottom right'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/UNDP-306.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2021/11/UNDP-306.jpg' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-41" class="widget widget_administerwidget"><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:100%;height:250px" data-full-width-responsive="true" data-ad-client="ca-pub-6732730031512336" data-ad-slot="9605720029"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id="administerwidget-42" class="widget widget_administerwidget"><div class='adsense-container '><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:100%;height:250px" data-full-width-responsive="true" data-ad-client="ca-pub-6732730031512336" data-ad-slot="1537364600"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id="administerwidget-43" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-80' class='administer-ad'><a id='administer-adlink-80' class='' href='https://dominicanewsonline.com/news/?administer_redirect_80=http%3A%2F%2Fwww.crimestoppersdominica.org' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Crime Stoppers'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2018/06/CSD-Dont-look-away-306.gif' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2018/06/CSD-Dont-look-away-306.gif' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="administerwidget-49" class="widget widget_administerwidget"><div class=' first-ad administer-ad-container'><div id='administer-ad-210' class='administer-ad'><a id='administer-adlink-210' class='' href='https://dominicanewsonline.com/news/?administer_redirect_210=http%3A%2F%2Fwww.weather.gov.dm%2F' onclick="if ( typeof(ga) == 'function' ) { ga('send', 'event', 'Advertisement', 'Click', 'Weather Widget Promotion'); }" target='_blank' rel='nofollow, noindex'><noscript><img src='https://dominicanewsonline.com/news/wp-content/uploads/2019/06/Weather-Report-min.jpg' style='width: 306px; height: 250px; ' width='306' height='250'   /></noscript><img class='lazyload' loading='lazy' data-src='https://dominicanewsonline.com/news/wp-content/uploads/2019/06/Weather-Report-min.jpg' style='width: 306px; height: 250px; ' width='306' height='250' /></a></div></div></section><section id="polls-widget-3" class="widget widget_polls-widget"><h2 class="widget-title">Polls</h2><p>Sorry, there are no polls available at the moment.</p></section></aside></div></div></div><footer id="colophon" class="site-footer container-fluid"><div class="site-info"><div class="row"><div class="col-sm-6"><ul class="footer-links"><li><a href="https://dominicanewsonline.com/news/policies/#privacy">Privacy Policy</a></li><li><a href="https://dominicanewsonline.com/news/policies/#disclaimers">Disclaimers</a></li><li><a href="https://dominicanewsonline.com/news/policies/#comment-policy">Comment Policy</a></li><li><a href="https://dominicanewsonline.com/news/policies/#faq">Frequently Asked Questions</a></li><li><a href="https://dominicanewsonline.com/news/contact/">Contact Us</a></li></ul></div><div class="col-sm-6"><p class="social-links"> <a class="social-link social-rss" target="_blank" title="Subscribe to our RSS Feed" href="https://feeds.feedburner.com/DominicaNewsOnline/"><i class="fas fa-rss-square fa-4x"></i></a> <a class="social-link social-facebook" target="_blank" title="Follow us on Facebook" href="https://www.facebook.com/DominicaNewsOnline"><i class="fab fa-facebook fa-4x"></i></a> <a class="social-link social-twitter" target="_blank" title="Follow us on Twitter" href="https://twitter.com/DNONews"><i class="fab fa-twitter-square fa-4x"></i></a> <a class="social-link social-instagram" target="_blank" title="Follow us on Instagram" href="https://www.instagram.com/dominicanewsonline"><i class="fab fa-instagram fa-4x"></i></a></p></div></div><p> <a href="https://dominicanewsonline.com/news/policies/#copyright">Copyright &#169; 2007-2021</a> Dominica News Online, Duravision Inc &#8226; Roseau, Dominica &#8226; All rights reserved.</p></div> <a id="back-to-top" class="back-to-top" title="Go to the top of the page" href="javascript:void(0)"><i class="fas fa-arrow-alt-circle-up fa-4x"></i></i></a></footer></div></div></div></div> <script type="text/javascript">function gcllCounter(textarea) {
if (textarea.value.length > 1000)
textarea.value = textarea.value.substring(0, 1000);
else
document.getElementById('commentlen').value = 1000 - textarea.value.length;
}</script>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='f7ba47c3641e34877f440ac644fef64c';
hf4V='e61b830ca53fa1765551829f0e05815a';
cm4S="form[action='https://dominicanewsonline.com/news/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <div id="fb-root"></div> <script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.1&appId=246787465390190&autoLogAppEvents=1';
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script> <script type="text/javascript" language="javascript">!function(d,s,id){
			var js,fjs=d.getElementsByTagName(s)[0];
			if(!d.getElementById(id)){
				js=d.createElement(s);
				js.id=id;js.src="//platform.twitter.com/widgets.js";
				fjs.parentNode.insertBefore(js,fjs);
			}
		}(document,"script","twitter-wjs");</script> <script type="text/javascript">var infolinks_pid = 3293537; var infolinks_wsid = 0;</script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script> <script>if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"https:\/\/dominicanewsonline.com\/news\/wp.serviceworker",
							{"scope":"\/news\/"}						).then( reg => {
													} );
					}
							} );
		}</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/lodash.min.js' id='lodash-js'></script> <script type='text/javascript' id='lodash-js-after'>window.lodash = _.noConflict();</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/react.min.js' id='react-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/react-dom.min.js' id='react-dom-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/escape-html.min.js' id='wp-escape-html-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/element.min.js' id='wp-element-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/html-entities.min.js' id='wp-html-entities-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script> <script type='text/javascript' id='wp-i18n-js-after'>wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/url.min.js' id='wp-url-js'></script> <script type='text/javascript' id='wp-api-fetch-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/api-fetch.min.js' id='wp-api-fetch-js'></script> <script type='text/javascript' id='wp-api-fetch-js-after'>wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://dominicanewsonline.com/news/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "eaacef58ef" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://dominicanewsonline.com/news/wp-admin/admin-ajax.php?action=rest-nonce";</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/vendor/moment.min.js' id='moment-js'></script> <script type='text/javascript' id='moment-js-after'>moment.updateLocale( 'en_US', {"months":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthsShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"weekdays":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"weekdaysShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"week":{"dow":0},"longDateFormat":{"LT":"g:i a","LTS":null,"L":null,"LL":"F j, Y","LLL":"F j, Y g:i a","LLLL":null}} );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script> <script type='text/javascript' id='wp-a11y-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/deprecated.min.js' id='wp-deprecated-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/dom.min.js' id='wp-dom-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/is-shallow-equal.min.js' id='wp-is-shallow-equal-js'></script> <script type='text/javascript' id='wp-keycodes-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/keycodes.min.js' id='wp-keycodes-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/priority-queue.min.js' id='wp-priority-queue-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/compose.min.js' id='wp-compose-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/date.min.js' id='wp-date-js'></script> <script type='text/javascript' id='wp-date-js-after'>wp.date.setSettings( {"l10n":{"locale":"en_US","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthsShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"weekdays":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"weekdaysShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"meridiem":{"am":"am","pm":"pm","AM":"AM","PM":"PM"},"relative":{"future":"%s from now","past":"%s ago"}},"formats":{"time":"g:i a","date":"F j, Y","datetime":"F j, Y g:i a","datetimeAbbreviated":"M j, Y g:i a"},"timezone":{"offset":-4,"string":"America\/Dominica","abbr":"AST"}} );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/primitives.min.js' id='wp-primitives-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/redux-routine.min.js' id='wp-redux-routine-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/data.min.js' id='wp-data-js'></script> <script type='text/javascript' id='wp-data-js-after'>( function() {
	var userId = 0;
	var storageKey = "WP_DATA_USER_" + userId;
	wp.data
		.use( wp.data.plugins.persistence, { storageKey: storageKey } );
	wp.data.plugins.persistence.__unstableMigrate( { storageKey: storageKey } );
} )();</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/rich-text.min.js' id='wp-rich-text-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/warning.min.js' id='wp-warning-js'></script> <script type='text/javascript' id='wp-components-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/dist/components.min.js' id='wp-components-js'></script> <script type='text/javascript' id='cookie-consent-js-extra'>var ctcc_vars = {"expiry":"30","method":"1","version":"1"};</script> <script type='text/javascript' id='wp-polls-js-extra'>var pollsL10n = {"ajax_url":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript' id='social_warfare_script-js-extra'>var socialWarfare = {"addons":[],"post_id":"277651","variables":{"emphasizeIcons":false,"powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};</script> <script type='text/javascript' data-cfasync='false' src='https://dominicanewsonline.com/news/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script type='text/javascript' id='navigation-cache-js-extra'>var page_nav_js_config = {"ajaxurl":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});</script> <script type='text/javascript' id='custom-functions-js-extra'>var dno_load_more_posts_config = {"ajaxurl":"https:\/\/dominicanewsonline.com\/news\/wp-admin\/admin-ajax.php","security":"4fad3e6ed5","max_page":"0"};</script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js' id='wpss-jscripts-ftr-js'></script> <script type='text/javascript' src='https://dominicanewsonline.com/news/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript">var swp_nonce = "b41bf7e4d7";var swpFloatBeforeContent = false; var swp_ajax_url = "https://dominicanewsonline.com/news/wp-admin/admin-ajax.php"; var swp_post_id = "277651";var swpClickTracking = false;</script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});</script> <div id="catapult-cookie-bar" class=" use_x_close"><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies to provide a better user experience. By using our site, you acknowledge that you have read and understand our Cookie Policy, Privacy Policy, and our Terms of Service. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://dominicanewsonline.com/news/policies/#cookie-policy">Find out more.</a></span><span class="ctcc-right-side"></span><div class="x_close"><span></span><span></span></div></div></div> <script defer src="https://dominicanewsonline.com/news/wp-content/cache/autoptimize/js/autoptimize_998d3782319ab89aa0cc02dac502d980.js"></script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6b2f75673d6d5ca6',m:'j6RP3ydm8x63L58HvHoicvQLj49GYe2vKCPRr5qSVvI-1637723577-0-AQN1zq8h8D+E9Ihoie7lnb9kEMa/vOxoEMsa96f0t5TlZzwsQ0CkCAR2J86gh1pFsK7l8W3Wd89EjvdiVE7z/dLkvAa0XoQPv7jmpYprcojkj9o58AUvVLwE6qVjnzavbhUKm5vuBTXSiMWucq5YdF6dlv1WXwhC6ltwyHZUz6iZeQmRQD+7F/wkjLokYmf+kUp9jjuHp/aHEvtxUVQ+ayq/4afOTwS4Ymj3WRBj5aL2SuTocYcN2JXstRj1WttB2mxGXRXECHY/eFnJZ6VqWk8gHalyojh6JKbhgGwlD/dw',s:[0xeccc9c52a1,0xa25c2c013e],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v64f9daad31f64f81be21cbef6184a5e31634941392597" integrity="sha512-gV/bogrUTVP2N3IzTDKzgP0Js1gg4fbwtYB6ftgLbKQu/V8yH2+lrKCfKHelh4SO3DPzKj4/glTO+tNJGDnb0A==" data-cf-beacon='{"rayId":"6b2f75673d6d5ca6","token":"683ff6fa5f72425db3f1d3af6385627c","version":"2021.11.0","si":100}' crossorigin="anonymous"></script>
</body></html>


